AutoSSL is including primary domain with addon domain in certificate

amalendukundu

Registered
Aug 13, 2017
2
0
1
India
cPanel Access Level
Website Owner
Hi,
Thank you for providing the great AutoSSL feature. I am on shared hosting and I am able to enable AutoSSL for my primary domain domain as well as all addon domains.

I have an issue though. The certificate for the addon domains is showing primary domain name. For example if the primary domain name is
www.primarydomain.com

and the add on domain is
www.addon1.com

When i see the certificate details in browser (Mozila/Chrome), it says the CN: Issued to addon1.primarydomain.com

This is annoying from owner and user prospective as for the addon domain uses they have nothing to know about the primary domain name.

How should the certificate shows Issued to: addon1.com (instead of including the primary domain name)

Regards,
Amal K
 

amalendukundu

Registered
Aug 13, 2017
2
0
1
India
cPanel Access Level
Website Owner
Hello,

This topic is discussed on the following thread:

Separate SSL certificates for Main & Add-on Domain

Thank you.
My problem is different. I have different SSL certificates for all my domains (primary and addon). My issue is for the SSL certificate on addon domain the having addon.primary.com as the first domain on the list of domain and thus the certificate is showing issued to addon.primary.com.

For example below the domain list of the SSl of one of the addon domain:
Code:
example.domain.com
mail.example.com
example.com
www.example.com
www.example.domain.com
If "example.com" would appear at first instead of "example.domain.com" then my certificate would shown
"Issued to : example.com"

This is the problem. Please let me know if my understanding is correct. If so, please let me know if there are any solution to this.
Regards,
Amalendu


mod note: actual domain names removed to protect privacy.
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello,

Here's a document that explains how AutoSSL sorts which domain names appear first in the certificate:

SSL FAQ and Troubleshooting - Documentation - cPanel Documentation

However, it looks like you are experiencing different behavior compared to what's documented. Could you open a support ticket using the link in my signature so we can take a closer look?

Thank you.