SOLVED AutoSSL not issuing certificate for whm.domain.com

HemanthJ

Member
Feb 28, 2012
9
1
51
cPanel Access Level
Root Administrator
Hi,

My VPS is on cPanel v72.0.11 and I have proxy sub-domains enabled. Recently,I started getting SSL errors with whm.domain.com.

Your connection is not secure

The owner of whm.domain.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

whm.domain.com uses an invalid security certificate. The certificate is only valid for the following names: domain.com, autodiscover.domain.com, cpanel.domain.com, mail.domain.com, webdisk.domain.com, webmail.domain.com, www.domain.com

Error code: SSL_ERROR_BAD_CERT_DOMAIN
I tried deleting the existing certificate from Manage SSL Hosts and creating new ones from Manage AutoSSL. But again it has omitted whm.domain.com. As you can see cpanel.domain.com works fine without any errors.

Please help.

Thanks
 

HemanthJ

Member
Feb 28, 2012
9
1
51
cPanel Access Level
Root Administrator
After a bit more digging, I've managed to fix the issue.

See this note:

AutoSSL only adds the whm proxy subdomain to the SSL certificate for reseller accounts.

SSL FAQ and Troubleshooting - Version 68 Documentation - cPanel Documentation

So, resolve the problem:

1. From Reseller Center grant the account reseller privileges.

2. Delete the existing certificate from Manage SSL Hosts

3. Request new certificates from Manage AutoSSL
 
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello @HemanthJ,

I'm happy to see you were able to solve the issue. Thank you for sharing the outcome!