autossl not renewing certificate

Agics

Member
May 16, 2013
16
0
1
Netherlands
cPanel Access Level
Root Administrator
I noticed today that several domains on my server running 72.0.7 had an expired ssl certificate. Running autossl did not fix this. Manage SSL showed them with an exclamation mark. I decided to remove the certificate and ran autossl again. No luck. Looking at the logs everything looks fine. I got things like:

Code:
Log for the AutoSSL run for “account”: Monday, July 2, 2018 9:22:05 PM GMT+0200 (cPanel (powered by Comodo))
9:22:05 PM AutoSSL’s configured provider is “cPanel (powered by Comodo)”.
Checking websites for “account” …
9:22:05 PM Checking “example.com” …
9:22:05 PM WARN (XID 765cmc) “account” does not own a domain named “ipv6.example.com” on this server.
9:22:05 PM Checking “blog.agics.nl” …
9:22:05 PM User-excluded domain: 1 (www.blog.example.com)
SUCCESS TLS Status: OK
Certificate expiry: 10/1/18, 12:00 AM UTC (90.19 days from now)
9:22:05 PM Checking “invoice.example.com” …
9:22:05 PM User-excluded domain: 1 (www.invoice.example.com)
SUCCESS TLS Status: OK
Certificate expiry: 10/1/18, 12:00 AM UTC (90.19 days from now)
9:22:05 PM Checking “manager.example.com” …
9:22:05 PM User-excluded domain: 1 (www.manager.example.com)
SUCCESS TLS Status: OK
Certificate expiry: 10/1/18, 12:00 AM UTC (90.19 days from now)
9:22:05 PM The system has completed the AutoSSL check for “account”.

Several domains (like the www.example.com are missing) In cpanel the domains show as unsecured as well and suggest to run autossl. The ipv6 address was manually excluded, the rest included.

Then I tried to include the ipv6 domain in autossl and it fixed the issue:

Code:
Log for the AutoSSL run for “account”: Monday, July 2, 2018 9:23:40 PM GMT+0200 (cPanel (powered by Comodo))
9:23:40 PM AutoSSL’s configured provider is “cPanel (powered by Comodo)”.
Checking websites for “account” …
9:23:40 PM Checking “example.com” …
9:23:40 PM ERROR TLS Status: Defective
ERROR Defect: NO_SSL: No SSL certificate is installed.
9:23:41 PM WARN Local DCV error (ipv6.example.com): “ipv6.example.com” does not resolve to any IPv4 addresses on the internet.
AutoSSL will request a new certificate.
9:23:41 PM Checking “blog.example.com” …
9:23:41 PM TLS Status: Incomplete
Certificate expiry: 10/1/18, 12:00 AM UTC (90.19 days from now)
Number of domains: 2
Number of secured domains: 1
WARN Local DCV error (www.blog.example.com): “www.example.com” does not resolve to any IPv4 addresses on the internet.
ERROR Impediment: NO_UNSECURED_DOMAIN_PASSED_DCV: Every unsecured domain failed DCV.
9:23:41 PM Checking “invoice.example.com” …
9:23:41 PM TLS Status: Incomplete
Certificate expiry: 10/1/18, 12:00 AM UTC (90.19 days from now)
Number of domains: 2
Number of secured domains: 1
WARN Local DCV error (www.invoice.example.com): “www.invoice.example.com” does not resolve to any IPv4 addresses on the internet.
ERROR Impediment: NO_UNSECURED_DOMAIN_PASSED_DCV: Every unsecured domain failed DCV.
9:23:41 PM Checking “manager.example.com” …
9:23:41 PM TLS Status: Incomplete
Certificate expiry: 10/1/18, 12:00 AM UTC (90.19 days from now)
Number of domains: 2
Number of secured domains: 1
WARN Local DCV error (www.manager.example.com): “www.manager.example.com” does not resolve to any IPv4 addresses on the internet.
ERROR Impediment: NO_UNSECURED_DOMAIN_PASSED_DCV: Every unsecured domain failed DCV.
9:23:41 PM The system will attempt to renew the SSL certificate for the website (example.com: example.nl www.example.nl mail.example.nl example.be www.example.be mail.example.be webmail.example.nl cpanel.example.nl autodiscover.example.nl webdisk.example.nl).
9:23:45 PM The system has completed the AutoSSL check for “account”.
9:24:01 PM The queue contains a request for a certificate for “account”’s website “example.com”. The system last polled for this certificate at Jul 2, 2018, 7:23:45 PM UTC. The next poll will be no earlier than Jul 2, 2018, 7:28:45 PM UTC.
9:29:01 PM Polling for “account”’s new certificate for “example.com” (order item ID “422408617”) …
9:29:02 PM The certificate is available. The system will now attempt to install it.
9:29:03 PM SUCCESS The certificate is now installed!
I could reproduce this to a number of other packages.

The issue is fixed for me now, but I'm wondering if this is a local issue or other users encounter this ?
 
Last edited:

24x7server

Well-Known Member
Apr 17, 2013
1,911
96
78
India
cPanel Access Level
Root Administrator
Twitter
Hi,

It appears to be issue related to the DNS. You have to make sure that the domain/their proxy subdomains point to your server only where you are initiating the AutoSSL.
Can you paste the logs of the AutoSSL here, so we can review it.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
HI @Agics

I'm happy the issue is resolved for you now, I am unaware of any issues we had that reflect what you experienced and I wonder if it may have been something network related at the time?