Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

AutoSSL on sub-domain stuck in pending

Discussion in 'Security' started by DATM, Jun 13, 2018.

  1. DATM

    DATM Registered

    Joined:
    Dec 18, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    51
    Hi,

    I have a few sub-domains stuck in the AutoSSL pending queue. One since the 9th.

    I have since run (today) Auto SSL on a new TLD domain and that has been issued and installed without any problems.

    When I run a check on one of the sub-domains I get the following in the log:
    Log for the AutoSSL run for “valleycu”: Wednesday, June 13, 2018 6:11:40 PM GMT+0100 (cPanel (powered by Comodo))
    6:11:40 PM AutoSSL’s configured provider is “cPanel (powered by Comodo)”.
    Checking websites for “valleycu” …
    6:11:40 PM Checking “valleycutters.example.uk” …
    6:11:40 PM User-excluded domains: 5 (www.valleycutters.example.uk, mail.valleycutters.example.uk, webmail.valleycutters.example.uk, cpanel.valleycutters.example.uk, webdisk.valleycutters.example.uk)
    ERROR TLS Status: Defective
    Certificate expiry: 6/11/19, 10:06 AM UTC (362.7 days from now)
    ERROR Defect: OPENSSL_VERIFY: The certificate chain failed OpenSSL’s verification (0:18:DEPTH_ZERO_SELF_SIGNED_CERT).
    AutoSSL will request a new certificate.
    6:11:40 PM The system will attempt to renew the SSL certificate for the website (valleycutters.example.uk: valleycutters.example.uk).
    The provider “cPanel (powered by Comodo)”’s AutoSSL queue already contains a request for a certificate for “valleycu”’s website “valleycutters.example.uk”. The request’s start time is Jun 11, 2018, 10:06:24 AM UTC and its last poll time is Jun 13, 2018, 9:36:02 AM UTC.
    6:11:40 PM The system has completed the AutoSSL check for “valleycu”

    Notes that may help:
    • I have other sub-domains under the same TLD that had previously installed without any problems.
    • Each sub-domain points at a separate hosting account.
    • The main TLD example.uk are on the same server and AutoSSL ran on that without a problem.
    • All sites are running on the same server/IP address as the TLD.

    Any help much appreciated.

    Cheers,
    Dave
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,042
    Likes Received:
    212
    Trophy Points:
    173
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    HI @DATM


    This sounds like the certificate is waiting on approval from Comodo. I removed the original domain name from your post but before I did I looked up the status of the certificate internally and requested that it restart the domain control validation check and I'm showing it's now been issued:
    Can you please confirm?

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. DATM

    DATM Registered

    Joined:
    Dec 18, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    51
    Thanks for that. I just ran a check and it's still giving the following error for the sub-domain:
    ERROR Defect: OPENSSL_VERIFY: The certificate chain failed OpenSSL’s verification (0:18:DEPTH_ZERO_SELF_SIGNED_CERT).

    Then it tries to request it and it's saying it's still in the queue
    The provider “cPanel (powered by Comodo)”’s AutoSSL queue already contains a request for a certificate for “username”’s website “sub-domain”. The request’s start time is Jun 11, 2018, 10:06:24 AM UTC and its last poll time is Jun 13, 2018, 9:36:02 AM UTC.

    All the other certificates I've requested have happened really quickly, including ones I've requested after these sub-domain ones.

    Many thanks,
    Dave
     
  4. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,042
    Likes Received:
    212
    Trophy Points:
    173
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @DATM

    I show 3 pending certificates for subdomains of the domain name I have issued them all now - it looks like we're investigating an issue related to the certificates not being issued properly right now. Please let me know if ALL the certs aren't present now.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. DATM

    DATM Registered

    Joined:
    Dec 18, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    51
    Hi @cPanelLauren
    They've all been issued now.
    Thanks for sorting that out. Will post here again if I get the same problem when I add them later.
    It was only on these sub-domains that I had a problem. Another accounts I set up with a TLD and standard www were issued with the certificate without any problems.
    Thanks again.
    Cheers,
    Dave
     
  6. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,042
    Likes Received:
    212
    Trophy Points:
    173
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi Dave,


    I'm glad to hear that, they progressed on our internal case as well and implemented a resolution so I don't think you should run into this issue again.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice