Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AUTOSSL sni not redirecting

Discussion in 'Security' started by sdevroey, Aug 19, 2017.

  1. sdevroey

    sdevroey Registered

    Aug 19, 2017
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello all,

    I've got the following issue :

    I have a VPS with WHM 64on CENTOS 7.3. This server is hosting 50+ websites/accounts/domains. Each domain has it's own SSL certificate through auto SSL.

    However when trying to reach a certain domain/website through Https i get an error SSL_ERROR_BAD_CERT_DOMAIN because the certificate relates to my server name ( instead of the domain of the website (

    The certificate for the domain is valid.
    Always redirect to SSL/TLS in tweaksettings is on
    The server IP is dedicated and shared with the websites/domains

    It seems to work for some domains, not for other.
    The domains that do not work have following options different as the domains that do work :
    - Is Primary Website on IP Address? Yes
    - Is SNI Required? No
    Where with the domains that are working it's the opposite.

    But I can't change these options ...

    Any pointers would be great.
    #1 sdevroey, Aug 19, 2017
    Last edited by a moderator: Aug 19, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator

    Can you verify if this relates to the domain name itself, or to proxy subdomains (e.g. cpanel.domain.tld)? Also, do you notice any error messages for the affected domain names under the "Logs" tab in "WHM >> Manage AutoSSL"?

    Thank you.

Share This Page