AutoSSL trouble after update from 70.x to 78.0.18

spaschke

Registered
Jan 9, 2019
2
0
1
US
cPanel Access Level
Website Owner
Before updating, AutoSSL was functioning correctly according to the logs.

After the update, I'm receiving the errors below:

FAILED: The DNS DCV check (X.server.X.com IN CNAME) did not return the expected value (X.X.comodoca.com).
Attempting HTTP DCV preflight check …
FAILED: Cpanel::Exception/(XID henjre) The system queried for a temporary file at “http://server.X.com/.well-known/pki-validation/X.txt”, but the web server responded with the following error: 404 (Not Found). A DNS (Domain Name System) or web server misconfiguration may exist.
at /usr/local/cpanel/Cpanel/SSL/DCV.pm line 404.

I've reviewed the errors covered in the stickied post, but they don't appear to be related to this message. Where should I go from here?
 

spaschke

Registered
Jan 9, 2019
2
0
1
US
cPanel Access Level
Website Owner
Hello @spaschke,

Can you open a support ticket so we can take a closer look at the system to see why the AutoSSL validation process is failing for that account? Post the ticket number here once it's opened and I'll link this thread to it.

Thank you.
After digging further, I've realized that the functionality wasn't working previously, either, but in the end, I don't intend to enable the functionality anyway - the domain is covered by an OV certificate.

If the behavior is unintentional, I'd still gladly send a ticket, but otherwise, it looks like I should just disable AutoSSL to avoid future unnecessary warnings.

Thanks
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,910
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @spaschke,

The errors are only intentional if the domain doesn't use the name servers associated with the cPanel server and the verification TXT file referenced in the log output is not accessible over Apache. Disabling AutoSSL for the account will address the issue, but feel free to contact us again should you encounter additional issues with AutoSSL.

Thank you.