dstana

Well-Known Member
Jul 6, 2016
90
15
8
Phoenix, AZ
cPanel Access Level
Root Administrator
I have a domain that for whatever reason got flagged by Google (was a brand new site) and now has the deceptive site warning. AutoSSL has had this domain's SSL in the queue for over 24 hours while other accounts that have been added to the server after this one have had their AutoSSL certs installed.

I used the Google Search Console to get the deceptive site warning removed, after checking this morning that's all taken care of and back to normal. But it says it's waiting on validation, but still hasn't come through. What can I do to move it along?
 
Last edited:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
Hello,

Sectigo won't install certificates on domains that are listed with Google's safe browsing. More than likely what happened is the certificate was rejected or will be rejected. It doesn't perform multiple checks for this on a single request as far as I am aware.

You could do one of the following:
1. Open a ticket with us to determine the status of the request and re-request the certificate (it requires we know either your IP address or domain name, neither of which should be added here)
2. Allow the request to time out, which is should fairly soon at this point.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
I'm so sorry @dstana this got overlooked by me. You can't cancel the cert requests on your end which is why I had initially suggested as an option to open a ticket as we can cancel the request with Sectigo. Were you able to get this resolved?