SOLVED autoupdate cron.weekly repo issue

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Dear members,
i receive the following issue in cron.weekly auto-update process:
Code:
/etc/cron.weekly/autoupdate:

Loaded plugins: fastestmirror, universal-hooks
Setting up Update Process
Determining fastest mirrors
 * EA4: 185.69.232.245
 * cpanel-addons-production-feed: 185.69.232.245
 * base: mirror.vpsnet.com
 * epel: mirror.vpsnet.com
 * extras: mirror.vpsnet.com
 * ius: ftp.acc.umu.se
 * updates: mirror.vpsnet.com
http://mirror.vpsnet.com/epel/6/x86_64/repodata/2f657a55bab0d7153511e03bc2145974d7b119cd9b231809fb294962059c7535-primary.xml.gz: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
To address this issue please refer to the below knowledge base article

[Errno 14] yum fails with HTTP/HTTPS Error 404 - Red Hat Customer Portal

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

No Packages marked for Update
as it seems the mirror link is dead and i assume that i have to change it to another one or remove it at all. I follow the quoted link to RedHat and they enforce me to subscribe in order to see the answer (what an old-fashioned way).
Anyway, i have never modified (add or remove) any mirror in general.

Thank you for your suggestions.
 
Last edited by a moderator:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,272
313
Houston

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Hello @cPanelLauren
unfortunately i was unable to find a solution in mirrors list from the file: /etc/yum.repos.d/CentOS-Base.repo as quoted in this link:
How to add different mirrors for update? Centos 6.4 - CentOS

The solution was found here:
[SOLVED] Yum attempting to Update/Install Packages - 404 Error Returned. - CentOS

I disabled the mirror:
from the file: /etc/yum.repos.d/epel.repo and i receive no 404 error now!


Thanks a lot!