Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Avoid domain.com/webmail redirect to https://hostname.com:2096

Discussion in 'General Discussion' started by stefanbc, Dec 2, 2015.

  1. stefanbc

    stefanbc Well-Known Member

    Joined:
    Apr 13, 2015
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    toronto
    cPanel Access Level:
    Root Administrator
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,309
    Likes Received:
    393
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    This is a setting in WHM > Tweak Settings > Redirection tab.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. stefanbc

    stefanbc Well-Known Member

    Joined:
    Apr 13, 2015
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    toronto
    cPanel Access Level:
    Root Administrator
    I tried the following without success

    Always redirect to SSL OFF
    Non-SSL redirect destination Origin Domain Name default
    SSL redirect destination SSL Certificate Name default

    If I am not mistaking https:// domain . com / webmail should not redirect to https://hostname.com:2096
    I have a secure certificate installed on https:// domain . com /

    Thank you
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,277
    Likes Received:
    1,846
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    SSL certificates for services such as cPanel/WHM/Webmail are not supported on a per domain basis. Instead, the service certificate installed via "WHM >> Service Configuration >> Manage Service SSL Certificate" is utilized. There's a feature request for what you are seeking at:

    SSL certificate per domain on all services

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. stefanbc

    stefanbc Well-Known Member

    Joined:
    Apr 13, 2015
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    toronto
    cPanel Access Level:
    Root Administrator
    Hi,

    I already know about that request. Is there a way to go around it from the terminal?

    My provider says that if I buy a secure certificate for webmail.domain.com they might be able to at least make the subdomain work without any ssl errors?

    Thank you
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,277
    Likes Received:
    1,846
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    There are two options as it stands now for accessing webmail.domain.com over SSL:

    1. Enable proxy subdomains, which forces the use of the SSL Certificate in "WHM Home » Service Configuration » Manage Service SSL Certificates".
    2. Disable proxy subdomains, and manually configure redirects for the subdomains to the proper SSL ports.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice