Avoid Exim logging exim -bpc

Operating System & Version
CloudLinux 7.9
cPanel & WHM Version
11.96.0.9

manoaratefy

Well-Known Member
Nov 17, 2018
53
5
8
Madagascar
cPanel Access Level
Root Administrator
Twitter
Hello,

I'm using exim -bpc commands to plot a graph in collectd for monitoring stuffs. At this time, each exim -bpc command launched involves a log entry. Having this running multiple times per seconds leads to a large logfile. Is there a way to avoid this command logged in logfiles?

Thanks in advance.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,810
892
313
cPanel Access Level
Root Administrator
Hey there! Any of the "exim -bp" options will leave a log entry similar to this in the exim_mainlog file:

Code:
2021-06-22 10:51:07 cwd=/root 2 args: exim -bpc
2021-06-22 10:53:03 cwd=/root 2 args: exim -bp
I don't see any options listed in the documentation that would keep this from logging:


This might be a good question for the Exim mailing list as this isn't specifically related to cPanel, but from my research I'm not finding a way around this.
 

rscalover

Well-Known Member
Dec 16, 2010
86
10
58
cPanel Access Level
Root Administrator
Hello,

What is your setting for "log_selector" this controls exim logging you can find it in whm under home=>service configuration=>exim configuration manager => advanced editor there look for "log_selector" but be carefull with changing it you do wanna be able to track spammers if needed :) also are you using any configserver plugins ? i believe csf needs certain certain settings in exim's log_selector to work correctly.
 

manoaratefy

Well-Known Member
Nov 17, 2018
53
5
8
Madagascar
cPanel Access Level
Root Administrator
Twitter
Hello,

What is your setting for "log_selector" this controls exim logging you can find it in whm under home=>service configuration=>exim configuration manager => advanced editor there look for "log_selector" but be carefull with changing it you do wanna be able to track spammers if needed :) also are you using any configserver plugins ? i believe csf needs certain certain settings in exim's log_selector to work correctly.
Thank you. I've just tried to replace +arguments to -arguments and it seems to work. But not sure if something else is affected or not.
 
  • Like
Reactions: cPRex