The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AWstats does not update automatically.

Discussion in 'General Discussion' started by SXR1337, Feb 22, 2008.

  1. SXR1337

    SXR1337 Member

    Joined:
    May 4, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    For some accounts on a few different servers running cPanel/WHM, awstats does not update automatically. I tweaked awstats to include the update now buttom to allow users to update from browser but somehow it reverts my changes after 24 hours or so . Does anyone has a solution? I need to have awstats update automatically. It appears that it is only malfunctioning for a few people , not for all.

    Please help.

    Thank you.
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Are you manually tweaking AWStats or enabling this functionality via WHM?
     
  3. SXR1337

    SXR1337 Member

    Joined:
    May 4, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Thank you for the reply. Im tweaking the config for a user in /home/user/tmp/awstats.

    Regards,
    SXR
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    It is possible that cPanel updates are overwriting that manual configuration.

    Have you considered going to WHM -> Server Configuration -> Tweak Settings -> Stats and Logs and checking Allow users to update Awstats from cPanel? Remember to click save after you check that box, if you do choose to do that.
     
  5. FrankyKnife

    FrankyKnife Member

    Joined:
    Mar 27, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Zurich (CH)
    hi!
    i have the same problem... the stats view of awstats is not updating automatically any more. and that for several months now!

    - strange thing is that is not on every domain like this. btw i have not done any manual modifications on the config files!

    - other web stats tools like webalizer work fine, on every domain/account.

    - on "WHM >> Main >> Server Configuration >> Statistics Software Configuration" awstats is active and enabled, schedule is every 24 h.

    - i tried /scripts/runlogsnow and /scripts/runweblogs. no change - no updates!

    - updating the stats by manually clicking on the link "update now" works, but if u dont do that every day manually u will have empty days... very nice!


    how can i reset or fix that again so it works automatically every day with an awstats update?
     
  6. FrankyKnife

    FrankyKnife Member

    Joined:
    Mar 27, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Zurich (CH)
    i have looked around a bit...

    it seems that some old versions of cpanel had a problem with awstats log updates, since june/july 2008. dont know why!?
    i have upgraded cpanel now to the latest stable version 11.24. moreover i have changed the statistics log rotation from 24h to 10h, blocked it in the time of my cpanel automatic update and backup times to prevent collision.

    ...now it works fine again!
     
Loading...

Share This Page