The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

awstats enabled afterwards

Discussion in 'General Discussion' started by dnagency, May 20, 2005.

  1. dnagency

    dnagency Active Member

    Joined:
    Oct 21, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    hello,

    i just enabled awstats for my server that already got several accounts on it. now i have that problem:

    in the cpanel of those accounts it shows now the link to awstats but when clicking on it, it gives back that error message:

    Error: Couldn't open config file "awstats.domain.tld.conf" nor "awstats.conf" after searching in path ".,/home/account/tmp/awstats/,/etc/opt/awstats,/etc/awstats,/etc,/usr/local/etc/awstats": No such file or directory

    - Did you use the correct URL ?
    Example: http://localhost/awstats/awstats.pl?config=mysite
    Example: http://127.0.0.1/cgi-bin/awstats.pl?config=mysite
    - Did you create your config file 'awstats.account.com.conf' ?
    If not, you can run "./../../tools/awstats_configure.pl" from command line, or create it manually.

    Check config file, permissions and AWStats documentation (in 'docs' directory).


    Now I wonder, wether I need to restart any service or something like that in order to have awstats working for those accounts?

    thx in advance :)
     
  2. challii

    challii Well-Known Member

    Joined:
    Feb 3, 2004
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
    Wait for a normal stats run to pass and the correct files should be created ... or you could try /scripts/runweblogsnow i think
     
  3. dnagency

    dnagency Active Member

    Joined:
    Oct 21, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    thx challii,

    I waited and files are there now obviously :)
     
Loading...

Share This Page