The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

awstats error/problem

Discussion in 'General Discussion' started by patchwork, Jul 27, 2003.

  1. patchwork

    patchwork Well-Known Member

    Joined:
    Nov 2, 2001
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    16
    I was wondering if anybody knows a quick way to fix this error, it seems like something happened over night to cause awstats to fail on all domains.

    If a user tries to access the stats from cpanel this error is displayed.

    If I go into the conf file the logfile entry reads LogFile=""

    if I change this to LogFile="/usr/local/apache/domlogs/username.com" the stats start working again on that domain.

    Is there some quick way of fixing this problem, it will be a very long job going through all the domains on the server and fixing this problem by hand.

    .

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  2. patchwork

    patchwork Well-Known Member

    Joined:
    Nov 2, 2001
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    16
    ok, It looks like the problem is partially down to /scripts/runweblogs

    If runweblogs cannot find the domain logfile it will change the logfile entry in the awstats .conf files.

    Running a command like "touch /usr/local/apache/domlogs/domain.com" before runweblogs will stop runweblogs from corrupting all the awstats conf files.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page