awstats has 1 in number of visits column

screege

Well-Known Member
Aug 11, 2004
190
1
166
Hey folks.

I have an odd one that appears to have occurred in one particularly busy web site only.

Awstats suddenly has "1" in Number of visits column (Days of the Month view). See attached.

Anyone else seen this happen before?
 

Attachments

screege

Well-Known Member
Aug 11, 2004
190
1
166
For anyone having this issue turned out it was nginx , now I must figure out how to correct it.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

Check to see if your system uses a custom vhost.local template in the /var/cpanel/templates/apache2 directory. The installation of Nginx may have commented out CustomLog entries in this template file which changes the way Apache VirtualHosts are written. I have seen some users have success with uncommenting the "CustomLog" entries in the vhost.local template and then rebuilding the Apache configuration file via /scripts/rebuildhttpdconf.

Thank you.
 

screege

Well-Known Member
Aug 11, 2004
190
1
166
I have the following under vhost.default

[% IF logstyle == 'combined' -%]
[%- IF !enable_piped_logs || !supported.mod_log_config -%]
CustomLog [% serverroot %]/domlogs/[% wildcard_safe(vhost.log_servername) %] combined
[%- END %]
[% ELSE %]
TransferLog [% serverroot %]/domlogs/[% wildcard_safe(vhost.log_servername) %]
[% END -%]
[% IF supported.mod_log_config && supported.mod_logio && !enable_piped_logs -%]
CustomLog [% serverroot %]/domlogs/[% wildcard_safe(vhost.log_servername) %]-bytes_log "%{%s}t %I .\n%{%s}t %O ."
[% END -%]

Regards