The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Awstats not update

Discussion in 'General Discussion' started by webstyler, Jul 6, 2010.

  1. webstyler

    webstyler Well-Known Member

    Joined:
    Nov 20, 2003
    Messages:
    432
    Likes Received:
    0
    Trophy Points:
    16
    hello

    Awstats not update

    All settings under WHM is ok but all users statistic is old

    I try under WHM to force update but nothing happen

    Also try under ssh:
    /usr/bin/perl /usr/local/cpanel/3rdparty/bin/awstats.pl -config=mydomain.com -LogFile=/usr/local/apache/domlogs/mydomain.com -update

    return error:
    Error: Couldn't open config file "awstats.mydomain.com.conf" nor "awstats.conf" after searching in path "/usr/local/cpanel/3rdparty/bin,/root/tmp/awstats/,/etc/opt/awstats,/etc/awstats,/etc,/usr/local/etc/awstats": No such file or directory

    --

    The file is under /home/mysite/tmp/awstats/ .. as always

    There is other domain that "haven't" conf file .. because awstats is ever started :/

    --

    I have already try with force upcp .. nothing

    any suggest ?
     
  2. aapkapratik

    aapkapratik Member

    Joined:
    Oct 26, 2009
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    In my opinion you should try the following steps. It worked in my case


    First check wheter the function of your cPanel user accounts to update Awstats manually is enabled or not.

    Login to WHM, then select Server Configuration ->> Tweak Settings.
    Scroll down to Stats and Logs.
    Check the box "Allow users to update Awstats from cPanel"


    Actully the update link for Awstats should be present in

    cPanel>>Logs >>Awstats option will show "Update Now" next to "Last Update".

    If The Link Doesn't Appear in cPanel :-

    You can also verify that the setting is actually enabled, by checking the AWStats Configuration File for a particular user.

    1. Login via SSH as root
    2. cd /home/username/tmp/awstats
    3. grep AllowToUpdateStatsFromBrowser awstats.example.com.conf
    4. It should be set to AllowToUpdateStatsFromBrowser=1
    5. If not, edit the file and save.
    6. restart cpanel : service cpanel restart


    Updating AWstats Manually through Shell :-

    You can use SSH to update the stats by issuing the following command:

    /scripts/runweblogs [username]

    where [username] is the cPanel username you wish to update.
     
    #2 aapkapratik, Jul 6, 2010
    Last edited: Jul 6, 2010
  3. webstyler

    webstyler Well-Known Member

    Joined:
    Nov 20, 2003
    Messages:
    432
    Likes Received:
    0
    Trophy Points:
    16
    Hello

    I have solved with this:

    1. kill update process (still run but not work)
    2. de-select awstats as active statistic software and save
    3. select awstats as active statistic software and save
    4. run single user update from WHM

    now seems work

    I really don't understand what exactly was wrong

    Thanks
     
Loading...

Share This Page