cPanelPeter

Technical Analyst III
Staff member
Sep 23, 2013
574
17
143
cPanel Access Level
Root Administrator
Twitter
Hello,

To confirm this was caused by a syntax error in the Apache configuration (httpd.conf) file. A syntax error will prevent Apache from restarting gracefully and will also prevent the domlogs from updating. They remain at 0 bytes so when stats runs, no data is available to update.
 

whipworks

Well-Known Member
Aug 19, 2014
169
7
68
cPanel Access Level
Reseller Owner
That is the problem that I'm interested.
It stopped registering activity. Last one was 3 days ago.
Then the succeeding days was just plain zero on all stats.
Even when the site have been visited.
cPanelPeter was able to resolve the issue. Unfortunately, I just found out that another server has the same issue. I'm thinking probably all of our CPanel server has this. I tried updating an SSL cert on one of our accounts and surely enough that mycpanel.pem does not exist. This is beginning to be a pain.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
That is the problem that I'm interested.
It stopped registering activity. Last one was 3 days ago.
Then the succeeding days was just plain zero on all stats.
Even when the site have been visited.
Have you reviewed the previous responses to this thread to see if any of them are helpful? Could you provide some more details about the troubleshooting steps you have taken thus far?

Thank you.
 

Mario Franco

Registered
Oct 24, 2014
4
0
1
Mexico City, Mexico, Mexico
cPanel Access Level
Root Administrator
Hello,

To confirm this was caused by a syntax error in the Apache configuration (httpd.conf) file. A syntax error will prevent Apache from restarting gracefully and will also prevent the domlogs from updating. They remain at 0 bytes so when stats runs, no data is available to update.
Hi,

I also have the same problem with all accounts in a server I'm currently managing. Awstats and other stats programs suddenly stopped updating. I've tried all the troubleshooting methods explained here and in other forums.

When updating from Shell (through runweblogs) I get the following message at the end of the output:
[2014-10-24 00:45:15 -0500] Skipping $username, no activity since 0 [Wed Dec 31 18:00:00 1969] (domains:1 domains)

Also I've restarted Apache to see if there was a misconfiguration in the httpd.conf file and it restarted without problem and the stats issue remains.

Any ideas what may be causing this?

Thanks!

Mario
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Are you using any third-party applications such as Nginx that alter the default Apache configuration?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Feel free to open a support ticket using the link in my signature and post the ticket number here.

Thank you.
 

cre8gr

Member
Nov 5, 2014
9
0
51
cPanel Access Level
Root Administrator
I'm having the same issues for 3 days now. My configuration has nginx as a proxy, but up until now bandwidth logs where calculated successfully.

This happens to all of the domains hosted. Some of them show bandwidth and user access only from AWstats (cPanel's Monthly Bandwidth Transfer is on halt), but I know it's wrong, as user access is much higher than what they say.

The only thing I remember changing is at /etc/named.conf where I added in both options and external:

recursion no;
additional-from-auth no;
additional-from-cache no;
To stop DNS query cache attacks.

I runned /scripts/runweblogs $username but that didn't do the trick either.

Also most of the domains have no entry in their /usr/local/apache/domlogs/domain.com file