The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Awstats stopped working

Discussion in 'General Discussion' started by dandanfireman, Jan 24, 2003.

  1. dandanfireman

    dandanfireman Well-Known Member
    PartnerNOC

    Joined:
    May 31, 2002
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    16
    AWstats on a couple of my servers stopped working nightly. I can force an update manually for the accounts by executing /scripts/runweblogs

    I submitted a ticket 3 days ago with no response.
     
  2. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    In /usr/local/cpanel
    cat cpanellogd and make sure that $skipawstats = 0; If it is set to 1 awstats will be skipped.
     
  3. dandanfireman

    dandanfireman Well-Known Member
    PartnerNOC

    Joined:
    May 31, 2002
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    16
    Oddly enough, one of my servers that awstats IS working on is also set to skip=1
     
  4. dandanfireman

    dandanfireman Well-Known Member
    PartnerNOC

    Joined:
    May 31, 2002
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    16
    I get this in the log file

    Error: Couldn't open config file &awstats.acoustic.com.conf& nor &awstats.conf& : No such file or directory
    Setup (Config file, web server or permissions) may be wrong.
    See AWStats documentation in 'docs' directory for informations on how to setup awstats.

    but the file is there in the /home/acoustic/tmp/awstats dir
     
  5. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Are the permissions okay?

    700 user:user awstats - directory

    644 user:user for the files in awstats.
     
  6. dandanfireman

    dandanfireman Well-Known Member
    PartnerNOC

    Joined:
    May 31, 2002
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    16
    yep
     
  7. carpman1

    carpman1 Member

    Joined:
    Jan 25, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I have correct settings in cpanellogd but it still will not run, pain.

    I have set stats to be run twice a day by using setting 0.5 for half day is this correct?
     
  8. dandanfireman

    dandanfireman Well-Known Member
    PartnerNOC

    Joined:
    May 31, 2002
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    16
    I believe I have found a workaround for this (thanks Burst.net).

    1. Turn off awstats in &Tweak settings&
    2. in ssh run /scripts/upcp
    3. Turn on awstats in &Tweak settings&
    4. in ssh run /scripts/upcp
     
  9. tcwebguy

    tcwebguy Active Member

    Joined:
    Sep 28, 2001
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    0
    Other Options?

    When I cat cpanellogd it shows skip_awstats = 1;

    But it shows this on the other server that is still processing Awstats correctly.

    Also, these vaules do not weem to change no matter what tweaking I do through WHM

    I also tries this last fix that was posted, and it does not seem to have any effect.

    Other ideas?
     
  10. dandanfireman

    dandanfireman Well-Known Member
    PartnerNOC

    Joined:
    May 31, 2002
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    16
    When I did both the editing of the file to make skipawstats = 0 and the disable, upcp, enable, upcp, it seems to have fixed it.

    Check /usr/local/cpanel/logs/stats_log to see if it is either getting an error or not running at all.
     
  11. tcwebguy

    tcwebguy Active Member

    Joined:
    Sep 28, 2001
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    0
    I just went into SSH and changed this.

    Will it simply be changed back every time I tweak settings?
     
  12. tcwebguy

    tcwebguy Active Member

    Joined:
    Sep 28, 2001
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    0
    This seems to be a tweak issue

    Okay, I have tried a number of configurations, and it seems to me that:

    1. Webalizer will not run more than once per day (frequency = 1) by using WHM settings
    2. skipawstats is not related to whether or not Awstats will run
    3. runlogsnow no longer works correctly
    4. once you have setup a .5 or .25 for frequency, Awstats will ignore any logs that were &processed& while Awstats was not operating correctly

    Has anyone been successful at getting Awstats to run more than once per day?

    How exactly did you do it?

    Glenn :)
     
  13. Snowman

    Snowman Member

    Joined:
    Sep 9, 2002
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Never mind got it sorted
     
Loading...

Share This Page