Awstats working randomly or not at all

vs-fam

Active Member
PartnerNOC
Mar 18, 2010
34
4
58
Hi,

On two Xen VPS awstats is working randomly or not at all. I get zero values for everyday, then one or two days I get stats, then zeros again. This happens with all domains.

I run /script/rubweblogs username and get no errors. I run /scripts/runstatsonce and /scripts/runlogsnow and same thing, no errors.

There are files at /home/user/tmp/awstats, but I guess they're missing data just like the data displayed.

In one server it stopped working right from Dec 29th (no stats at all since then). The other stopped working right from august of last year (random updates since then with no data at all in between).

Space quota is not the issue since there is plenty in several accounts and yet no stats for them either.

Where else should I look into for a fix ?

Thanks
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello :)

You can check the following log file to see if any errors are occurring during the statistics update process:

Code:
/usr/local/cpanel/logs/stats_log
If the problem is not evident from that, I suggest opening a support ticket so we can check further:

Submit A Ticket

Thank you.
 

vs-fam

Active Member
PartnerNOC
Mar 18, 2010
34
4
58
I opened a ticket (through our vendor, not directly) and got this from support:
Hi,

You're running nginx:

Since the webserver is what writes the logs that webstats process, and we do not support nginix on servers at all, this means I we can't continue to toubleshoot.

In all likelihood, the very fact that you're running nginix is the very reason stats are not updating.
Apache is still running on these servers. Nginx is being used as a reverse proxy for static content.

We have nginx in other servers as well and we're not having problems there. Actually, we have had nginx on these servers in question from some time now and the problem has just started a few days ago.

IMHO, cPanel support is just taking the easiest way out.
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
You mentioned that you opened a ticket through your vendor, rather than directly through cPanel. Assuming you have root access to the server, could you open a support ticket with us directly so we may check further?

Submit A Ticket

Thank you.
 

vs-fam

Active Member
PartnerNOC
Mar 18, 2010
34
4
58
Issue resolved. cPanel staff were great and kind.

It was because of nameservers in resolv.conf were being blocked by firewall.

Never could have guess it.