The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Backup attempting to prune remote destination, ignoring settings

Discussion in 'Data Protection' started by Smartypants.com, May 1, 2015.

  1. Smartypants.com

    Smartypants.com Registered

    Joined:
    May 1, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    No thanks
    cPanel Access Level:
    Root Administrator
    Backup attempting to prune remote destination, ignoring settings

    There appears to be a persistent issue with the new backup system - it's attempting to prune remote backups, even though I have it configured not to. I have both weekly and monthly backups enabled, via the new backup system - configured to copy the backups to a remote SFTP server.

    Since the backup config lacks any "never delete remote backups" option, I have both the weekly and montly backups configured to retain the past 9999 backups - with " Retain backups in the default backup directory" disabled. But every time the backup runs - both weekly & monthly - I get an EMail with an error saying:

    "The following errors occurred while transporting your backup files:

    Unable to prune transport “[TRANSPORTNAME]”"

    This happened again today when the monthly backup ran. When I check I the remore server (the backup destination), there is a grand total of 3 previous backups - clearly less than 9999 (the value of the "Retain weekly/montly backups" setting), so WHY is the backup system ignoring that setting & still trying to prune the remote backup anyway?

    This appears to somewhat related to an issue that was reported over a year ago (though still not fixed, as of the most recent post - from November 2014):

    https://forums.cpanel.net/threads/unable-to-prune-transport-server.397801/

    However in this case, my issue is NOT that the pruning fails - but that it shouldn't be attempting to prune in the first place. If anything, if that issue is ever actually fixed, then I'm very concerned it could result in lost backups (unless the issue with the "retain backups" setting is also fixed).
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page