Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

backup IO prio ignored

Discussion in 'Data Protection' started by fate12, Nov 17, 2016.

Tags:
  1. fate12

    fate12 Active Member

    Joined:
    Oct 29, 2013
    Messages:
    41
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Because the backups on my server takes far too long to run (24 hrs) I tried to lower the IO level in the 'tweak settings'.

    I entered 3 in the prio field, but the backup is still runs with lvl 4:

    [2016-11-17 00:15:03 +0100] info [backup] Setting I/O priority to reduce system load: none: prio 4

    The backup on this server takes forver.
    The other servers with the same specs and amount of data take 15 hrs to complete, on this server it takes 24 to 30+ hrs.

    Load is within bounds.
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,698
    Likes Received:
    1,883
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The availability of ionice depends on the I/O scheduler utilized on your system. You can run the following command to see if a scheduler is enabled:

    Code:
    cat /sys/block/$sda/queue/scheduler
    Replace $sda with your disk name (e.g. sda, vda). There's also a useful thread on StackOverflow on schedulers at:

    Selecting a Linux I/O Scheduler

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice