The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Backup on NFS and quotas

Discussion in 'General Discussion' started by clopezi, Nov 22, 2015.

  1. clopezi

    clopezi Member

    Joined:
    Mar 17, 2013
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    The backup directory (NFS) for my server is "/mnt/nfs/...", and the remote directory is IP:/home/backup.

    But when i'm going to enable quotas on my server, it says:
    How can be possible? I tried fixquotas and same error again and again.

    Thanks!
     
  2. Eric

    Eric Administrator
    Staff Member

    Joined:
    Nov 25, 2007
    Messages:
    746
    Likes Received:
    11
    Trophy Points:
    18
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Can you dump your /etc/fstab here?
     
  3. clopezi

    clopezi Member

    Joined:
    Mar 17, 2013
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Of course:

    Code:
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    /dev/sda2       /       ext3    errors=remount-ro,usrjquota=quota.user,jqfmt=vfsv0      0       1
    /dev/sda3       /home   ext4    noatime,nodiratime,usrquota     1       2
    /dev/sda4       swap    swap    defaults        0       0
    proc            /proc   proc    defaults                0       0
    sysfs           /sys    sysfs   defaults                0       0
    tmpfs           /dev/shm        tmpfs   rw,noexec,nosuid,nodev,noatime,nodiratime       0       0
    devpts          /dev/pts        devpts  defaults        0       0
    /tmp             /var/tmp                    ext3    defaults,bind,noauto,noatime,nodiratime        0 0
    176.31...:/home/copia /mnt/nfs/home   nfs      auto,noatime,nolock,bg,nfsvers=3,intr,tcp,actimeo=1800 0 0
    tmpfs /tmp/apc tmpfs size=4096M 0 0
    tmpfs /tmp/nginx_client tmpfs size=4096M 0 0
    
    Thanks!
     
  4. acenetgeorge

    acenetgeorge Well-Known Member
    PartnerNOC

    Joined:
    Mar 6, 2008
    Messages:
    64
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Southfield, MI
    cPanel Access Level:
    DataCenter Provider
    Quotas are not possible in NFS without some work. Quotas have to be enabled on the NFS server, then you have to manually deal with rpc.rquotad and rquotad commands to pass quota info remotely.

    We briefly looked into this a couple of years ago, and its not really worth all the manual effort. Easier to just add a 4TB hard drive to your server for backups :)
     
  5. clopezi

    clopezi Member

    Joined:
    Mar 17, 2013
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I may be badly explained. I want to enable quotas on my cPanel server, in /home, not in the NFS unit, but the server says that i have my backups in /home so disable quotas.

    Thanks!
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The message you are referring to is a warning, however quotas should still work for your accounts in /home based on the output of your /etc/fstab. Are quotas functioning as expected?

    Thank you.
     
Loading...

Share This Page