The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Backup Problems

Discussion in 'General Discussion' started by screege, Sep 22, 2004.

  1. screege

    screege Well-Known Member

    Joined:
    Aug 11, 2004
    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    16
    Hi my backups were running fine untill last week here is a log:

    PHP version file is up to date
    Cpanel updates are coming from layer2.cpanel.net findutils passes checksum net-tools passes checksum Checking /dev/hda....OK Checking /dev/hdc....Excessive Errors send to CONTACTEMAIL (3) [3] x - creating lock directory x - SKIPPING /usr/local/lib/php.ini (file already exists) Added Contact benjamin_aharonov@hotmail.com Rebuilding Process List...Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning.....Done Scanning suexec_log.Done Copying Reseller Config...Done Copying SSL Certificates, CSRS, and Keys...Done Copying Mail files....Done Copying frontpage file....Done Copying proftpd file....Done Grabbing mysql dbs...Done Grabbing mysql privs...Done Copying mailman lists....Done Copying mailman archives....Done Copying homedir....Done Copying cpuser file.......Done Copying crontab file.......Done Copying quota info.......Done Storing Subdomains....
    Done
    Storing Parked Domains....
    Done
    Storing Addon Domains....
    Done
    Copying password.......Done
    Copying shell.......Done
    pkgacctfile is: /home/cpbackuptmp/cpbackup/daily/archive.tar.gz
    Creating Archive ....Done
    md5sum is: 1c6db2a5e54a19eb06d75a4ad1d5dd8d Waiting for load to go down to continue Waiting for load to go down to continue Waiting for load to go down to continue Can't call method "login" on an undefined value at /scripts/cpbackup line 391, <PWCACHEENT> line 37.

    Also when executing /scripts/cpbackup it just stops saying me Daily Backup is up to date

    I deleted the whole directory from /home/cpbackuptmp and when runnning again the script here is what I get:

    root@server1 [/home]# /scripts/cpbackup
    Copying Reseller Config...Done
    Copying SSL Certificates, CSRS, and Keys...Done
    Copying Mail files....Done
    Copying proftpd file....Done
    Grabbing mysql dbs...Done
    Grabbing mysql privs...Done
    Copying mailman lists....Done
    Copying mailman archives....Done
    Copying homedir....Done
    Copying cpuser file.......Done
    Copying crontab file.......Done
    Copying quota info.......Done
    Storing Subdomains....
    Done
    Storing Parked Domains....
    Done
    Storing Addon Domains....
    Done
    Copying password.......Done
    Copying shell.......Done
    pkgacctfile is: /home/cpbackuptmp/cpbackup/daily/maugold.tar.gz
    Creating Archive ....Done
    md5sum is: 6111d31723c022c6c8ed564954822e41
    Can't call method "login" on an undefined value at /scripts/cpbackup line 391, <
    PWCACHEENT> line 38.
    root@server1 [/home]# /scripts/cpbackup
    Daily Backup is up to date
    Copying Reseller Config...Done
    Copying SSL Certificates, CSRS, and Keys...Done
    Copying Mail files....Done
    Copying proftpd file....Done
    Grabbing mysql dbs...Done
    Grabbing mysql privs...Done
    Copying mailman lists....Done
    Copying mailman archives....Done
    Copying homedir....Done
    Copying cpuser file.......Done
    Copying crontab file.......Done
    Copying quota info.......Done
    Storing Subdomains....
    Done
    Storing Parked Domains....
    Done
    Storing Addon Domains....
    Done
    Copying password.......Done
    Copying shell.......Done
    pkgacctfile is: /home/cpbackuptmp/cpbackup/weekly/maugold.tar.gz
    Creating Archive ....Done
    md5sum is: 608bec9e180f908de4d4bc35753ac8ad
    Can't call method "login" on an undefined value at /scripts/cpbackup line 391, <
    PWCACHEENT> line 38.

    And it stops.

    Can anybody help me?

    Thank you
     
  2. preleaf

    preleaf Well-Known Member

    Joined:
    Aug 25, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    hi you,
    guide me the way backup system .Thanks
     
  3. JamesSmith

    JamesSmith Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    185
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK, Luton
    I need an answer to this also, trying to test FTP transfer to our storage machine, after a few attempts running /scripts/cpbackups it now just exits with:

    web7# /scripts/cpbackup
    Daily Backup is up to date
     
  4. JamesSmith

    JamesSmith Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    185
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK, Luton
    I was doing daily backups, rm -rf'ed /usr/home/cpbackuptmp/cpbackup/daily and its now running succsessfully.
     
  5. preleaf

    preleaf Well-Known Member

    Joined:
    Aug 25, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    guide me step by step backup system .Because I go to /usr but i dont see home directory .And when I use rm -rf'ed /usr/home/cpbackuptmp/cpbackup/daily then it is display >
    >
    so help me STEP BY STEP.THanks so much
     
  6. JamesSmith

    JamesSmith Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    185
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK, Luton
    /me bangs head on wall

    Our machines run FreeBSD, so /usr/home is relevant, no doubt you're using a flavour of Linux. If so run the following:

    rm -rf /home/cpbackuptmp/cpbackup/daily

    I can only say what worked for us. If you want a more comprehensive response submit a ticket to CPanel support.
     
  7. screege

    screege Well-Known Member

    Joined:
    Aug 11, 2004
    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    16
    Worked

    After deleting it for about 3 days, now the daily backups work, not my weekly only daily and monthly. Hope the weekly may be done soon.

    Thanks
     
Loading...

Share This Page