The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Backups are made with a username and not root

Discussion in 'Data Protection' started by bsasninja, Jan 16, 2011.

  1. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    This is something extrange, backups at /backup folder are made under the username of a domain I have instead of root.

    How can I fix that? Cause all time the domain is warning my that is running ot of space.

    Thank you!
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    What backup method are you using (please provide the cPanel > Backup > Configure Backup settings you have)? Some of the types of backup could save the backup as the user instead of root, although you could always chown them to root:root periodically via a cron.
     
  3. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I recommend ensuring that your backup drive or partition has file system quotas disabled, or ensure that your backups are stored on a separate drive or partition that is not mounted with file system quota support from the OS. By having your backups stored on a drive or partition that uses file system quotas, as provided by your Operating System, this will inherently include that quota information when calculating disk usage for individual users.

    Please let us know the output of the following commands, entered via "root" SSH access:
    Code:
    # cat /etc/cpbackup.conf
    # cat /etc/mtab
     
Loading...

Share This Page