Backups are validating correctly to remote server, but still not backing up correctly?

system-error

Member
Dec 16, 2014
21
1
3
cPanel Access Level
Root Administrator
I am backing up 5 different WHM servers to one remote FTP server. 4 of the servers work fine and daily backup via FTP to the remote server. However, one WHM server is not backing up -- I do not see any *.tar.gz files on the remote backup server.

When I go to the WHM server and click Validate, it appears fine and I get the "Success: “backupserver” validated." message. But ultimately, each day there are no backups on the remote server. The WHM server is correctly daily and weekly backing up to its own backup directory on its local server, but it is not remotely sending the files to the backup server.

Is there a way to troubleshoot or check error logs on the WHM? All I see are the Validate button, and that works fine. But remote backups are not working. Any idea what to do next? Thank you.
 

system-error

Member
Dec 16, 2014
21
1
3
cPanel Access Level
Root Administrator
Sorry and here are the details of the WHM server:

Code:
/etc/redhat-release:CloudLinux Server release 6.7 (Aleksei Gubarev)
/usr/local/cpanel/version:11.54.0.21
/var/cpanel/envtype:kvm
CPANEL=release
Server version: Apache/2.4.18 (Unix)
Server built:   Feb 16 2016 17:20:50
Cpanel::Easy::Apache v3.32.10 rev9999 +cloudlinux
PHP 5.6.18 (cli) (built: Feb 16 2016 17:27:57)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
mysql  Ver 14.14 Distrib 5.5.48, for Linux (x86_64) using readline 5.1
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,241
363

system-error

Member
Dec 16, 2014
21
1
3
cPanel Access Level
Root Administrator
Thanks for the tip. Ok I had Legacy on, but not Backups. So I turned that on. I then went into the Legacy settings and arranged that. Now I will wait a day and see if this works ;)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,241
363
New Thanks for the tip. Ok I had Legacy on, but not Backups. So I turned that on. I then went into the Legacy settings and arranged that. Now I will wait a day and see if this works ;)
Note that you can disable legacy backups if you have enabled the default backup system. You can also force a backup generation with the following command if you prefer to not wait until the next automatic backup generation:

Code:
/usr/local/cpanel/bin/backup --force
Thank you.
 

system-error

Member
Dec 16, 2014
21
1
3
cPanel Access Level
Root Administrator
Great, many thanks. For some reason backups are now working. The legacy is disabled, but now all works fine. Strange that the settings were the same as all my other WHM servers. I will continue to monitor to make sure all is fine over the coming weeks. Thanks again!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,241
363
I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.