Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bad address length for Socket transfer tool error

Discussion in 'Data Protection' started by bryan20171116, Nov 16, 2017.

  1. bryan20171116

    bryan20171116 Registered

    Joined:
    Nov 16, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Malaysia
    cPanel Access Level:
    Root Administrator
    When I try to transfer the website from other cpanel account, I got this error message.

    My cpanel version is v68.0.13, CENTOS 6.9 virtuozzo

    Code:
    RESTORE: Account “xxxxx”: Account Restore Failed: “Account failure: Bad address length for Socket::inet_ntop on AF_INET6; got 4, should be 16 at /usr/local/cpanel/Cpanel/Ips.pm line 49. ”
    Any one can help please.
     

    Attached Files:

  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,675
    Likes Received:
    73
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    Error of this type generally occurs when you are using a system without an IPv6-enabled kernel. Please check te

    ----------------------- -----------------------
    cPanel & WHM require to have kernel that includes the ipv6 module, or includes that functionality directly within the kernel.

    If your kernel does not include it in the ipv6 module, the AF_INET6 address family must also be available.

    Most distributed kernels include this support by default. However, some users of custom kernels may experience problems.
    ----------------------- -----------------------

    Check if your server has IPv6 enabled in the kernel or not..
     
  3. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    27
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
    I concur with the previous comment. You can confirm if IPv6 is disabled in the kernel as below:
    Code:
    # cat /proc/net/if_inet6
    00000000000000000000000000000001 01 80 10 80       lo
    fe80000000000000f8163efffeae37e6 02 40 20 80     eth0
    
    If no file is found, then IPv6 is disabled.
     
  4. bryan20171116

    bryan20171116 Registered

    Joined:
    Nov 16, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Malaysia
    cPanel Access Level:
    Root Administrator
    The results as below.
    Code:
    cat: /proc/net/if_inet6: No such file or directory
    How to enable the IPv6 ?
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    You will need to contact your VPS hosting provider to see if they support setting up an IPv6-enabled kernel. Note that you don't actually need an IPv6 address, just support for it in the kernel.

    Thank you.
     
  6. bryan20171116

    bryan20171116 Registered

    Joined:
    Nov 16, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Malaysia
    cPanel Access Level:
    Root Administrator
    If the VPS hosting provider don't support setting up an IPv6-enabled kernel, Is there any way that can solved the issue?
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    No, if the server is already upgraded to cPanel version 68, then your VPS provider will need to facilitate support for an IPv6-enabled kernel to ensure cPanel & WHM operate properly.

    Thank you.
     
  8. WhiteDog

    WhiteDog Well-Known Member

    Joined:
    Feb 19, 2008
    Messages:
    127
    Likes Received:
    1
    Trophy Points:
    66
    I am getting a similar error when resetting a DNS zone.
    I am also missing the file /proc/net/if_inet6

    I'm not on a VPS however. The server is running CentOS 6.9 with the standard kernel + KernelCare. Have this issue on multiple servers. Never did anything specific towards IPv6 on these servers.

    How to resolve this? I assume some parameter just needs to flipped and the server rebooted...

    EDIT:
    Just resolved this. In my case it was the file /etc/modprobe.d/ipv6.conf that contained this:

    Code:
    # Anaconda disabling ipv6
    options ipv6 disable=1
    Set to 0 and rebooted... problems solved !
    Assume Anaconda is the system the DC used to install the OS at the time.
     
    #8 WhiteDog, Dec 3, 2017
    Last edited: Dec 3, 2017
    Dave Smith likes this.
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm glad to see you were able to solve the issue. Thank you for sharing the outcome.
     
  10. bryan20171116

    bryan20171116 Registered

    Joined:
    Nov 16, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Malaysia
    cPanel Access Level:
    Root Administrator
    I couldn't find the flie ipv.conf at /etc/modprobe.d/ipv6.conf

    is this cause the issue ?
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Is this a VPS? If so, check with your VPS hosting provider to see if it's possible to enable IPv6 support in the kernel.

    Thank you.
     
  12. Dave Smith

    Dave Smith Active Member

    Joined:
    Mar 20, 2016
    Messages:
    37
    Likes Received:
    9
    Trophy Points:
    8
    Location:
    Lisbon
    cPanel Access Level:
    Root Administrator
    Thank you for posting your fix, it worked for us perfectly after hours of head banging. Really appreciated!
     
    cPanelMichael likes this.
  13. GilbertoArias

    GilbertoArias Registered

    Joined:
    Sep 3, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    mex
    cPanel Access Level:
    Reseller Owner
    Hey hello every one! I have a solution, I was figthing with this one month so the solutions that works for me is:

    just change the origin server account you want to migrate from "automatic" to "Local" this in th MX records using the WHM interface.
    save changes and... taran... it works.

    I have to thanks Daniel A from Godaddy IT team support he toldme that so save my migration domines weekend.

    my origin server has cpanel 66.0.36 version and the new one 68.0.25 and both of them CentOS base 6.9 obviously hosted those VPS with this provider!

    Try the solution

    Log Before change:

    ---
    Bad address length for Socket::inet_ntop on AF_INET6; got 4, should be 16 at
    /usr/local/cpanel/Cpanel/Ips.pm line 49.

    Removing copied archive “/home/cpmove-sanje.tar.gz.part00001” from the local server …
    Failed: Account Restore Failed: “Account failure:
    Bad address length for Socket::inet_ntop on AF_INET6;
    got 4, should be 16 at /usr/local/cpanel/Cpanel/Ips.pm line 49. ”

    ---

    Log After change:

    ---
    Completed
    TRANSFER: 1 completed, 0 had warnings, and 0 failed.
    RESTORE: 1 completed, 0 had warnings, and 0 failed.


    ---
     
Loading...

Share This Page