The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bad HELO - Host impersonating

Discussion in 'E-mail Discussions' started by spiderlinginc, Apr 18, 2016.

  1. spiderlinginc

    spiderlinginc Member

    Joined:
    Mar 15, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I have set up a new server with a different provider, but with the same hostname as my current/old server. I moved a couple of test accounts to the new server and the DNS records on the old server were all updated with the new server's IP. I manually changed the E-mail Routing to Remote Mail Exchanger for the transferred account on the old server. E-mail messages from an external (off server) e-mail account are received. However, when I send an e-mail from an account on the old server to an account that was transferred and still on the old server, I receive "smtp; 550-"REJECTED - Bad HELO - Host impersonating". Can I not have the both accounts running at the same time for precautionary sake? There are several accounts that rely on e-mail very much, and they would be very upset if there were any issues.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can browse to "WHM >> Service Configuration >> Exim Configuration Manager" on the destination server and disable the "Require remote (hostname/IP address) HELO" option, or add the source server IP address to the "Trusted SMTP IP addresses" option.

    Thank you.
     
  3. spiderlinginc

    spiderlinginc Member

    Joined:
    Mar 15, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Thanks Michael.
    Tried the first setting and it didn't work then added the second and still not working. Just to confirm, by destination server you mean the new server, correct?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Yes, I am referring to the new server when stating "Destination Server". Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. spiderlinginc

    spiderlinginc Member

    Joined:
    Mar 15, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I made an additional change, but misplaced the the note of which one. :rolleyes: The messages are now being sent. I've included a snapshot of the ACL and Mail settings in hopes you might see which setting it was.

    My other issue is that both servers have the same hostname. Clients are using the hostname for their incoming and outgoing server settings for their e-mail programs/devices. I have a server-wide SSL for e-mail as well. I'm trying to avoid having the clients make any changes. I'd like to transfer their accounts and not "bother" them. Possible?

    upload_2016-5-13_12-14-59.png

    upload_2016-5-13_12-16-56.png
     
    #5 spiderlinginc, May 13, 2016
    Last edited: May 13, 2016
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You should use separate hostnames for each server because the hostname will only resolve to a single IP address.

    Thank you.
     
    spiderlinginc likes this.
Loading...

Share This Page