Bareword found where operator expected (quickinstall)

bayleafmedia

Registered
Jun 6, 2019
3
0
1
united states
cPanel Access Level
Website Owner
Good morning,

This is my first post, and this may not be the place to put this but I began receiving the following error this morning:

Bareword found where operator expected at /usr/local/cpanel/Cpanel/URI/Escape/Fast.pm line 22, near "s/([^A-Za-z0-9\-_\.~])/$escapes{$1}/gr"


I've read through a few posts and most answers state that we should go to our hosting providers to receive support on installed 3rd party QuickInstall software packages.

Here is one of those posts: Bareword found where operator expected error

I have called my host. They cannot find fast.pm on my system, and state that this is an "out of scope" issue: They do not deal with custom scripting. I have no QuickInstall products installed on my system, and I am not using fast.pm anywhere as far as I can tell.

This looks to me to be a host issue. Might there be anything I can go back to them with if they cannot find the file?

thanks
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,234
363
cPanel Access Level
DataCenter Provider
Twitter
I have called my host. They cannot find fast.pm on my system, and state that this is an "out of scope" issue: They do not deal with custom scripting. I have no QuickInstall products installed on my system, and I am not using fast.pm anywhere as far as I can tell.
Hello @bayleafmedia,

Can you clarify where you are seeing this error message? Is it in the cPanel UI or do you receive an email notification pertaining to this error?

Thank you.
 

bayleafmedia

Registered
Jun 6, 2019
3
0
1
united states
cPanel Access Level
Website Owner
Thanks,

yes, I received this message two days in a row by email from cron on my webhost. I did not see this in the console UI. However, today I did not receive this error.

thanks again
 

bayleafmedia

Registered
Jun 6, 2019
3
0
1
united states
cPanel Access Level
Website Owner
So, today marks error notice number three. Same thing in the body of the email:

Subject Line: Cron <[email protected]> /usr/local/bin/perl /usr/local/cpanel/3rdparty/quickinstall/scripts/checkupdates.pl

Body Content: Bareword found where operator expected at /usr/local/cpanel/Cpanel/URI/Escape/Fast.pm line 22, near "s/([^A-Za-z0-9\-_\.~])/$escapes{$1}/gr"

No errors in the cpanel error log, no errors in my file manager (where most of my cron errors would go).
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,234
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @bayleafmedia,

This is a third-party application that's not included by default with cPanel & WHM. I recommend contacting your hosting provider again and verifying if /usr/local/cpanel/3rdparty/quickinstall/scripts/checkupdates.pl is part of the cPanel & WHM image they offer.

Or, if you have root access and do not utilize this plugin, check to see if any "uninstall" scripts exist under /usr/local/cpanel/3rdparty/quickinstall/ or it's sub-directories.

Thank you.