Beware FrontPage Extensions and Apache 2.4

vicos

Well-Known Member
Apr 18, 2003
82
3
158
For those of us that are going to use FrontPage Extensions to the bitter end. Just discovered that the extensions will not work properly with Apache 2.4. 2.2 is the latest supported version. By not working properly, you will not be able to connect to the FrontPage web, you will typically get a 500 error back when trying to connect/authenticate.

Although the documentation notes this issue:

Apache Module: FrontPage

easyApache will not flag it and will build Apache 2.4 with the FP extensions.

Thanks to the guys at LiquidWeb who discovered this tidbit.

Just an FYI for anyone who might encounter this issue.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

This is similar to the discussion on the following thread:

cPanel and Frontpage

Per our documentation:

Since Microsoft® discontinued support for mod_frontpage extensions on Linux servers in 2006, we have also marked the FrontPage service in cPanel & WHM as End-Of-Life. FrontPage will be removed from EasyApache by the end of 2013. We strongly recommend that you use another method to publish content, such WebDAV or FTP. FrontPage extensions will still be available as a Custom Module (“Opt Mods”) for EasyApache; however, we strongly discourage its use and the Custom Module is only compatible with Apache version 2.2.

Thank you.
 

vicos

Well-Known Member
Apr 18, 2003
82
3
158
Thanks Michael, I understand the issue with FrontPage at end of life. Just trying to save someone aggravation due to the fact that easyApache will compile with FP ext and Apache 2.4 even though it won't work and is not flagged as an issue during configuration.

BTW, is there a post/document you recommend that fully explains using WebDAV with CPANEL and all related issues? I'd be happy to use this if it will replace FP extensions, but am hesitant to just turn it on w/o fully understanding it.
 
Last edited: