The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Big DNS issue

Discussion in 'Bind / DNS / Nameserver Issues' started by Steve Kadest, Sep 13, 2012.

  1. Steve Kadest

    Steve Kadest Registered

    Joined:
    Sep 13, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Portland, Oregon, United States
    cPanel Access Level:
    Root Administrator
    A while ago the domain owner of my site's email was compromised and we had to switch to another domain. Easy enough. We just recently got the domain name back and upon trying to switch back, it said the domain was already registered. So, I just deleted the cpanel account and remade it and it let me use the old domain.

    Ever since I did this, the server has not been able to resolve any domains and isn't even able to ping IP addresses. My DNS configuration is so messed up that I'm not sure how to fix it.

    Here is the output of /etc/resolv.conf:

    HTML:
    r2k6a@server [~]# cat /etc/resolv.conf
    # Generated by NetworkManager
    search 2006scape.com
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    
    Here is tcpdump output during normal operation:
    HTML:
    02:45:07.219995 IP 195.148.177.110.65514 > myServerIP.domain: 11770 A? myDomain.com. (31)
    02:45:07.220293 IP myServerIP.domain > 195.148.177.110.65514: 11770 ServFail- 0/0/0 (31)
    02:45:07.267246 IP 195.148.177.110.65514 > myServerIP.domain: 11770 A? myDomain.com. (31)
    02:45:07.267400 IP myServerIP.domain > 195.148.177.110.65514: 11770 ServFail- 0/0/0 (31)
    02:45:07.314982 IP 195.148.177.110.65514 > myServerIP.domain: 11770 A? myDomain.com. (31)
    02:45:07.315133 IP myServerIP.domain > 195.148.177.110.65514: 11770 ServFail- 0/0/0 (31)
    
    Sometimes when my server attempts to resolve domain names, it does it in this format, which I know isn't right:
    HTML:
    some.site.com.mydomain.com
    
    I have tried the various scripts, fixndc, updatenameservers, etc. Nothing seems to fix it. If I add
    HTML:
    nameserver 127.0.0.1
    to resolv.conf I'm able to resolve domains but I'm still not able to ping anything. Up until a hour or so ago, my site was fully operational. Now, I'm only able to access it through SSH.

    Does anyone have any idea what could be causing this? Can provide any information.. Operating system is Centos6.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Whats this?
    search 2006scape.com
     
  3. Steve Kadest

    Steve Kadest Registered

    Joined:
    Sep 13, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Portland, Oregon, United States
    cPanel Access Level:
    Root Administrator
    my domain.. it was in there and automatically generated by' network manager'
     
Loading...

Share This Page