Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Big problem happened with mysql !

Discussion in 'General Discussion' started by dendis, Sep 2, 2004.

  1. dendis

    dendis Well-Known Member

    Joined:
    Jul 18, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    156
    I have try to move to MYSQL 3 and here came error.

    Then again tried back to MYSQL 4 and the same error:

    Using Mysql4
    bandmin is up to date (Tue Apr 8 09:00:52 2003)
    chkservd is up to date (Thu Aug 19 13:05:17 2004)
    MySQL-server is not up to date (Wed Dec 31 18:00:00 1969)
    Testing connection speed...(this could take a while)......Done
    MySQL-embedded is up to date (Sat May 15 22:00:43 2004)
    MySQL-client is not up to date (Thu Mar 13 13:13:56 2003)
    MySQL-devel is not up to date (Thu Mar 13 13:13:56 2003)
    MySQL-bench is not up to date (Thu Mar 13 13:13:56 2003)
    MySQL-shared is not up to date (Thu Mar 13 13:13:56 2003)
    MySQL-shared-compat is not up to date (Wed Dec 31 18:00:00 1969)
    portsentry is up to date (Tue Jan 29 20:02:40 2002)

    Fetching Obsoletes list for channel: rhel-i386-es-3...

    Fetching rpm headers...

    Name Version Rel
    ----------------------------------------------------------
    bind-devel 9.2.4 EL3_10 i386
    bind-utils 9.2.4 EL3_10 i386
    expect 5.38.0 92.2 i386
    gcc 3.2.3 42 i386
    openssl 0.9.7a 33.12 i686
    openssl-devel 0.9.7a 33.12 i386


    Testing package set / solving RPM inter-dependencies...
    There was a package dependency problem. The message was:

    To solve all dependencies for the RPMs you have selected, The following
    packages you have marked to exclude would have to be added to the set:

    Package Name Reason For Skipping
    ==================================================
    ====================
    bind-9.2.4-EL3_10 Config modified
    bind-9.2.4-EL3_10 Config modified
    bind-9.2.4-EL3_10 Config modified

    Unresolvable chain of dependencies:
    bind 9.2.2-21 requires libdns.so.8
    bind 9.2.2-21 requires libisc.so.4
    bind-devel-9.2.4-EL3_10 requires bind = 10:9.2.4-EL3_10



    Don't have idea what is happening here!
    Now when starting mysql we get:

    Can't execute /usr/bin/mysqld_safe from dir /var/lib


    More stuff to see:
    root@gama [/usr/bin]# ./mysql
    ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    root@gama [/usr/bin]# ./mysql_config
    Usage: ./mysql_config [OPTIONS]
    Options:
    --cflags [-I'/usr/include/mysql']
    --libs [-L'/usr/lib/mysql' -lmysqlclient -lz -lcrypt -lnsl -lm -lc -lnss_files -lnss_dns -lresolv -lc -lnss_files -lnss_dns -lresolv]
    --socket [/var/lib/mysql/mysql.sock]
    --port [3306]
    --version [3.23.56]

    root@gama [/usr/bin]# /usr/bin/mysqld_safe
    -bash: /usr/bin/mysqld_safe: No such file or directory


    Hmm version --version [3.23.56] ??

    Anyway if someone could help me.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice