Big Server Response time - please help me

nnnswordfish

Member
Jul 27, 2018
14
2
3
Georgia
cPanel Access Level
Root Administrator
Hi all,

My server response time is very slow, it might take around 20 seconds to load the first time any page,
then if you will continue browsing on the site and open the second or third random pages immediately (around 1- 10 seconds interval) everything loads fine and fast, but if you will stop browsing for 12-20 seconds and after that continue browsing again you will get big delays opening of pages again.

Feels like It takes some time to connect with the server but if you are connected then it accepts your requests unless you stop browsing around 10 secs, then again you will have delays before the server accepts your request again.

Also, I have traced rout and here is what I found - there is a big delay to connecting server - please see the video





These links are opening very fast.

what do you think about this? do you have any ideas what might cause this delay? I have chat with hosting guys and they told me that this is not DDos stack but they are work on this to figure out what is this - they still have no answer :(.
or maybe it the global DNS server issue? due to the coronavirus servers are overloaded because people are using too many internet while they are at home?

Please note:
when you will check my site it might be that for you it will load fine and fast - but just recheck it in few minutes again and you will see the issue, this issue is random, but in most cases (90%), it presents.

Please help me.
 
Last edited by a moderator:

dalem

Well-Known Member
PartnerNOC
Oct 24, 2003
2,957
139
368
SLC
cPanel Access Level
DataCenter Provider
check out some other sites on the server if you can see if they are slowing down
Seems like a poorly optimized WordPress site (cache enabled? )
takes 30 seconds to load no mater where its checked from
how are the server loads?
 

nnnswordfish

Member
Jul 27, 2018
14
2
3
Georgia
cPanel Access Level
Root Administrator
1. check out some other sites on the server if you can see if they are slowing down - will do
2. Yes cache is enabled and everything was working fine before this
3. Server load is fine - there is no extra Cpu or ram usage - everything runs fine
 

dalem

Well-Known Member
PartnerNOC
Oct 24, 2003
2,957
139
368
SLC
cPanel Access Level
DataCenter Provider
Had a client with the same issue WP can be a dog if its not optimized.
Moved them to their VPS with Memcache installed sites load fast.
They had 10 WP sites 8 out of the ten were slow 2 were fine.
Of the 8 they were all running the same plugins and a variation of the same theme.
One of the plugins or the theme was slowing it down.

You can try disabling the plugins and enabling them 1 by 1 to see if you can find the culprit.
 

nnnswordfish

Member
Jul 27, 2018
14
2
3
Georgia
cPanel Access Level
Root Administrator
This looks like a networking issue, if you're running traceroute and seeing delays. It's extremely likely with more and more people staying home some service providers will become overloaded.
Thank you, what you think about this:
"
Feels like It takes some time to connect with the server but if you are connected then it accepts your requests and you are browsing with normal delays/speed unless you stop browsing around 10 secs, then again you will have delays before the server accepts your request again.
"

Can network issues cause something like this?