The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BIND broken after last nights upcp

Discussion in 'Bind / DNS / Nameserver Issues' started by sloop, Dec 3, 2007.

  1. sloop

    sloop Well-Known Member
    PartnerNOC

    Joined:
    May 4, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    north carolina
    I had two WHM/Cpanel servers where BIND was not running this morning after last night's upcp. Both servers are set to receive security updates only.

    The problem was that /etc/rndc.key was set to 0600 owned by root. I changed ownership to named and then was able to restart BIND.

    Did anyone else see this problem? I am going to update these servers to the latest STABLE but just wondered if I was alone.
     
  2. serversignature

    serversignature Well-Known Member

    Joined:
    Nov 26, 2007
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bangalore
    hi,

    You can try using the command named-checkconf and named-checkzone commands

    usage: named-checkconf [-j] [-v] [-z] [-t directory] [named.conf]
    usage: named-checkzone [-djqvD] [-c class] [-o output] [-t directory] [-w directory] [-k (ignore|warn|fail)] [-n (ignore|warn|fail)] zonename filename

    Simply run command as follows:
    # named-checkconf /etc/named.conf

    If there is no output, the configuration is considered correct

    Just .. check out /var/log/messages also is any issues.

    Thanks,
     
Loading...

Share This Page