The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BIND - DNS Problems - need help

Discussion in 'Bind / DNS / Nameserver Issues' started by eglwolf, Apr 12, 2005.

  1. eglwolf

    eglwolf Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    I just set up a VPS server with Centos 3.4 and all seemed to work well, however after updating the domain over to the new nameservers, and configuring those at the domain registrar. The site dies, it seems that the bind is not working correctly. I tried using /scripts/fixdnc but that did not resolve the problem. Which is:

    Apr 12 12:34:58 ve300 named[21792]: zone customer_domain.com/IN: loading master file /var/named/customer_domain.com.db: file not found
    Apr 12 12:34:58 ve300 named[21792]: zone ve300.customer_domain.com/IN: loading master file /var/named/ve300.customer_domain.com.db: file not found
    Apr 12 12:34:58 ve300 named[21792]: zone customer_domain.com/IN: loading master file /var/named/customer_domain.com.db: file not found


    It is not loading the dns zones. I tried to delete and recreate them in whm, and that did not work. Same error. I have verified that these files fo exist in the /var/named directory.

    Can anyone give me a hand resolving this issue?
     
  2. reggie

    reggie Member

    Joined:
    Apr 10, 2002
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    centos DNS problems

    Hi all
    I have just had the same problem, it seems that centos creates a chrooted environment for named.
    Cpanel locates the zone files in /var/named I was getting the same error file not found, I noticed the directory /var/named/chroot/var/named so I copied all of the zone files into there and restarted named, and guess what named could suddenly find the zone files and I was then able to get an authortive response using NSLOOKUP for the domains.
    I have submitted a ticket with cpanel.net to find out if there is a fix for this problem.
    cheers, Reggie
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You can simply disable the chroot named by editing /etc/sysconfig/named and comment out the line that begins with:

    ROOTDIR=

    Then move your .db files to /var/named and chown the directory to the named user:

    chown -R named:named /var/named

    Then restart named:

    /etc/init.d/named restart
     
  4. jdarow

    jdarow Well-Known Member
    PartnerNOC

    Joined:
    May 30, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Michigan, US
    cPanel Access Level:
    DataCenter Provider
    Thanks Chirpy!

    This just helped me.

    Thanks Chirpy!
     
Loading...

Share This Page