Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

bind error

Discussion in 'Bind/DNS/Nameserver' started by mickalo, Feb 7, 2007.

  1. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    773
    Likes Received:
    4
    Trophy Points:
    318
    Location:
    N.W. Iowa
    Hello,

    we updated bind via the up2date earlier today:
    Code:
    bind-chroot-9.2.4-24.EL4
    bind-libs-9.2.4-24.EL4
    bind-9.2.4-24.EL4
    bind-devel-9.2.4-24.EL4
    bind-utils-9.2.4-24.EL4
    
    when named is restarted we get this error now:
    Code:
    service named status
    rndc: no key definition for name rndckey
    
    According to previous posting with this type of problem, running the /scripts/fixrndc is suppose to fix this problem. Is this the correct method to solve this issue ?

    Update:
    after further digging, found the problem in the rndc.conf and after correcting it, that seem to fix the problem.


    Thx's
    Mickalo
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 mickalo, Feb 7, 2007
    Last edited: Feb 7, 2007
  2. WillyBoy

    WillyBoy Member

    Joined:
    Jan 23, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    151
    How did you fix it? If possible please include the steps taken :)
    thanks,
    WillyBoy
     
  3. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    773
    Likes Received:
    4
    Trophy Points:
    318
    Location:
    N.W. Iowa
    In my case I had to change the rndc.conf after the update. open the /etc/rndc.confc and change this:
    Code:
    options {
            default-server  localhost;
            default-key     "rndckey";
    };
    
    server localhost {
            key     "rndckey";
    };
    
    To this:
    Code:
    options {
            default-server  localhost;
            default-key     "key";
    };
    
    server localhost {
            key     "key";
    }
    
    the "rndckey" need to be changed to "key"

    Hope this helps
    Mickalo
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    rs-freddo likes this.
  4. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    Thanks..............
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. yaax

    yaax Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    156
    Thanks that also helped me.
     
  6. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    773
    Likes Received:
    4
    Trophy Points:
    318
    Location:
    N.W. Iowa
    no specific effects, it was just a type-O error in the file, referencing the wrong key name.

    Mickalo
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. lbeachmike

    lbeachmike Well-Known Member

    Joined:
    Dec 27, 2001
    Messages:
    306
    Likes Received:
    1
    Trophy Points:
    316
    Location:
    Long Beach, NY
    cPanel Access Level:
    Root Administrator
    What is the specific effect this change has?

    Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice