Bind failing every 8-9 minutes

CRego3D

Active Member
Aug 13, 2001
38
0
306
Anybody havign this problem ?, on 2 of my servers, bing fails every 8-9 minutes for 40 minutes, then it goes 20 minutes with no problem, then it repeats itself

and .. even when it fails, I see that bind IS indeed running .. this is all I get in the logs (nothing .. really)

----snip---
Aug 24 14:24:49 merlin named[30538]: listening on IPv4 interface eth0:254, 64.46.99.254#53
Aug 24 14:24:49 merlin named[30538]: command channel listening on 127.0.0.1#953
Aug 24 14:24:49 merlin named[30538]: running
Aug 24 14:26:34 merlin proftpd[30049]: 64.46.99.11 (i197-041.nv.iinet.net.au[203.59.197.41]) - FTP no transfer timeou
t, disconnected.
Aug 24 14:26:34 merlin PAM_pwdb[30049]: (ftp) session closed for user thebhg
Aug 24 14:28:23 merlin named: named shutdown failed
Aug 24 14:28:23 merlin named: named shutdown failed
Aug 24 14:28:23 merlin named[30996]: starting BIND 9.1.0 -u named
Aug 24 14:28:23 merlin named[30996]: using 2 CPUs
Aug 24 14:28:23 merlin named[30998]: loading configuration from \'/etc/named.conf\'
----snip---

I left the proftp entry there, so you can see, there is no error between bind starting and bind .. re-starting .. any ideas ? :)
 
B

bdraco

Guest
bind 9.1 has its share of crash problems. We are considering making packages for the latest version of bind, however we don\'t want to cause any new problems (I\'m sure there will be if we do).. If someone wants to test new bind packages, let me know.

[quote:e667172112]Anybody havign this problem ?, on 2 of my servers, bing fails every 8-9 minutes for 40 minutes, then it goes 20 minutes with no problem, then it repeats itself

and .. even when it fails, I see that bind IS indeed running .. this is all I get in the logs (nothing .. really)

----snip---
Aug 24 14:24:49 merlin named[30538]: listening on IPv4 interface eth0:254, 64.46.99.254#53
Aug 24 14:24:49 merlin named[30538]: command channel listening on 127.0.0.1#953
Aug 24 14:24:49 merlin named[30538]: running
Aug 24 14:26:34 merlin proftpd[30049]: 64.46.99.11 (i197-041.nv.iinet.net.au[203.59.197.41]) - FTP no transfer timeou
t, disconnected.
Aug 24 14:26:34 merlin PAM_pwdb[30049]: (ftp) session closed for user thebhg
Aug 24 14:28:23 merlin named: named shutdown failed
Aug 24 14:28:23 merlin named: named shutdown failed
Aug 24 14:28:23 merlin named[30996]: starting BIND 9.1.0 -u named
Aug 24 14:28:23 merlin named[30996]: using 2 CPUs
Aug 24 14:28:23 merlin named[30998]: loading configuration from \'/etc/named.conf\'
----snip---

I left the proftp entry there, so you can see, there is no error between bind starting and bind .. re-starting .. any ideas ? :) [/quote:e667172112]
 

WHN-Si

Member
Aug 15, 2001
13
0
301
we\'ve had the same problems on our more loaded servers. Basically bind8 seems to dislike more than about 300 or so zones, then it starts crashing.

Firstly I would go through your zones and make sure there aren\'t any invalid ones or double ups in /var/named
Then add a cron that restarts bind every 30 mins, that seems to stabilise it.

regards,

Simon
 

moronhead

Well-Known Member
Aug 12, 2001
706
0
316
Simon,
[quote:6533c6c7c8]Then add a cron that restarts bind every 30 mins, that seems to stabilise it.
[/quote:6533c6c7c8]
Can you give us an idea of what the command line should be for bind to restart as a cron? Thanks.
 

rpmws

Well-Known Member
Aug 14, 2001
1,822
9
318
back woods of NC, USA
restart bind to get zone to load more than likely is caused by a ndc connect fail ... there is a thread in here somewhere about a key you put into named.cond to fix that.

I have been told that bind will fail often if you have more than one zone entry to the same zone in named.conf. Well not exactally. What I have found is if you have 2 entries for the same zone and the exact entries are slightly different in spacing or position in the file, bind doesn\'t like that. I have found a reseller that deleted a domain and added it back did this to me. Seems deleting a domain doesn\'t remove the named.conf entry.
 

WHN-Si

Member
Aug 15, 2001
13
0
301
/etc/rc.d/init.d/named restart
 

aroiz

Registered
Dec 27, 2001
3
0
301
I have this problem the bind service fail every 8 or 10 minutes, How repair it...
 

JapAniManga.ch

Well-Known Member
Aug 11, 2001
88
0
306
Switzerland
I have this Problem with Apache who fails every Day (1x - 4x a Day, from Day to Day diffrent) and this since (~) two Weeks :(