The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bind problem

Discussion in 'Bind / DNS / Nameserver Issues' started by ashd, Feb 19, 2005.

  1. ashd

    ashd Member

    Joined:
    Feb 19, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Hi, i just got a server running cpanel and whm, and bind fails and fails over and over, it first started happening when i was configuring the nameservers and now bind just wont work, i have run fixndc and it has made no difference,
    when i run '/etc/rc.d/init.d/named restart; tail -50 /var/log/messages'
    i get the following output from ssh :
    'Feb 19 07:23:25 localhost named[11400]: loading configuration: failure
    Feb 19 07:23:25 localhost named[11400]: exiting (due to fatal error)
    Feb 19 07:24:26 localhost pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 19 07:24:26 localhost pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 19 07:32:49 localhost named: named shutdown failed
    Feb 19 07:32:49 localhost named: Removing chroot jail succeeded
    Feb 19 07:32:49 localhost named: Removing chroot jail succeeded
    Feb 19 07:32:49 localhost named: Setting up chroot jail succeeded
    Feb 19 07:32:49 localhost named[11587]: starting BIND 9.2.3 -u named -c /etc/named.conf -t /var/lib/named/chroot
    Feb 19 07:32:49 localhost named[11587]: using 1 CPU
    Feb 19 07:32:49 localhost named[11587]: loading configuration from '/etc/named.conf'
    Feb 19 07:32:49 localhost named[11587]: /etc/named.conf:220: when using 'view' statements, all zones must be in views
    Feb 19 07:32:49 localhost named[11587]: loading configuration: failure
    Feb 19 07:32:49 localhost named[11587]: exiting (due to fatal error)
    Feb 19 07:32:49 localhost named: named startup succeeded
    Feb 19 07:33:50 localhost pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 19 07:33:50 localhost pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Feb 19 07:37:46 localhost named: named shutdown failed
    Feb 19 07:37:46 localhost named: Removing chroot jail succeeded
    Feb 19 07:37:46 localhost named: Removing chroot jail succeeded
    Feb 19 07:37:46 localhost named: Setting up chroot jail succeeded
    Feb 19 07:37:46 localhost named[11740]: starting BIND 9.2.3 -u named -c /etc/named.conf -t /var/lib/named/chroot
    Feb 19 07:37:46 localhost named[11740]: using 1 CPU
    Feb 19 07:37:46 localhost named: named startup succeeded
    Feb 19 07:37:46 localhost named[11740]: loading configuration from '/etc/named.conf'
    Feb 19 07:37:46 localhost named[11740]: /etc/named.conf:220: when using 'view' statements, all zones must be in views
    Feb 19 07:37:46 localhost named[11740]: loading configuration: failure
    Feb 19 07:37:46 localhost named[11740]: exiting (due to fatal error)
    Feb 19 07:42:13 localhost named: named shutdown failed
    Feb 19 07:42:13 localhost named: Removing chroot jail succeeded
    Feb 19 07:42:13 localhost named: Removing chroot jail succeeded
    Feb 19 07:42:13 localhost named: Setting up chroot jail succeeded
    Feb 19 07:42:13 localhost named[11868]: starting BIND 9.2.3 -u named -c /etc/named.conf -t /var/lib/named/chroot
    Feb 19 07:42:13 localhost named[11868]: using 1 CPU
    Feb 19 07:42:13 localhost named: named startup succeeded
    Feb 19 07:42:13 localhost named[11868]: loading configuration from '/etc/named.conf'
    Feb 19 07:42:13 localhost named[11868]: /etc/named.conf:220: when using 'view' statements, all zones must be in views
    Feb 19 07:42:13 localhost named[11868]: loading configuration: failure
    Feb 19 07:42:13 localhost named[11868]: exiting (due to fatal error)
    Feb 19 07:42:15 localhost named: Removing chroot jail succeeded
    Feb 19 07:42:15 localhost named: Setting up chroot jail succeeded
    Feb 19 07:42:15 localhost named[11925]: starting BIND 9.2.3 -u named -c /etc/named.conf -t /var/lib/named/chroot
    Feb 19 07:42:15 localhost named[11925]: using 1 CPU
    Feb 19 07:42:15 localhost named: named startup succeeded
    Feb 19 07:42:15 localhost named[11925]: loading configuration from '/etc/named.conf'
    Feb 19 07:42:15 localhost named[11925]: /etc/named.conf:220: when using 'view' statements, all zones must be in views
    Feb 19 07:42:15 localhost named[11925]: loading configuration: failure
    Feb 19 07:42:15 localhost named[11925]: exiting (due to fatal error)
    Feb 19 07:43:14 localhost pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Feb 19 07:43:14 localhost pure-ftpd: (?@127.0.0.1) [INFO] Logout.'

    I have no idea what to do to fix it and would be really appreciative of any help you could give me,

    Thanks,
    Ash
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Have you run the following script at least twice:

    /scripts/fixndc

    If not, do so.
     
  3. ashd

    ashd Member

    Joined:
    Feb 19, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    yes, i ran that and it didn't do much, i found the problem and apparently fixed the problem manually, although now resin keeps failing, and after creating my first user in cpanel, it configured httpd.conf with a line break in the DocumentRoot parameter so apache crashes unless i manually modify it, and although bind no longer fails, when attempting to change dns settings i still get "Error reloading bind on server: rndc: 'reload' failed: not found"
    if anyone could help me fix these problems and get my server working i would be most greatful,
     
    #3 ashd, Feb 19, 2005
    Last edited: Feb 19, 2005
  4. ntwaddel

    ntwaddel Well-Known Member

    Joined:
    Nov 3, 2003
    Messages:
    173
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Templeton, CA
    it sounds like you are using trustix, they have an in view and an out view setup in the default named config. cpanel doesent really deal with this very well, i just removed the two views on my configuration and that should get it working
     
  5. ashd

    ashd Member

    Joined:
    Feb 19, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    yea i'm using trustix, there are three views in the config files, should i leave the tighten-chaos one?
    and also i'm having trouble when creating new users, i get an error when creating them '/home/public_html does not exist or is not a directory!' and it also puts a line break in httpd.conf eg

    '
    <VirtualHost 207.226.21.171>
    ServerAlias www.mhatma.co.uk mhatma.co.uk
    ServerAdmin webmaster@mhatma.co.uk
    DocumentRoot /home
    /mhatmac/public_html

    BytesLog domlogs/mhatma.co.uk-bytes_log
    ServerName www.mhatma.co.uk
    User mhatmac
    Group mhatmac
    TransferLog domlogs/mhatma.co.uk
    </VirtualHost>
    '
    which causes apache to fail, any ideas on that?
     
    #5 ashd, Feb 19, 2005
    Last edited: Feb 19, 2005
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You could check your cat /etc/wwwacct.conf and make sure there are no spurious characters or linefeeds around the HOMEDIR variable.
     
Loading...

Share This Page