The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bind problems

Discussion in 'Bind / DNS / Nameserver Issues' started by itrends, Dec 6, 2004.

  1. itrends

    itrends Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    So, now i've got a problem.

    Our system uses 2 named.conf files. weird enough only one get's updated by Cpanel itself. When i add an domain it updates /etc/namedb/named.conf.. but when bind start's it uses the /etc/named.conf

    I try'd symlinks (both ways) but cpanel overwrites them whatever i do..

    is there a sollution to my problem? Now i have to delete the file, make an symlink and restart the nameserver everytime..
     
  2. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    What distro are you running? I have RHEL and there is no directory called /etc/namedb are you perhaps running bsd?
     
  3. itrends

    itrends Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Yeah, FreeBSD 4.x
     
  4. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Add this line to your rc.conf file and reboot


    named_flags="-u bind -c /etc/namedb/named.conf"
     
  5. itrends

    itrends Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Does nothing..

    Bind says:
    0:00.21 /usr/sbin/named -u bind -c /etc/named.conf
     
  6. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    When you restart Bind, what does it say in /var/log/messages ?
     
  7. itrends

    itrends Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    No errors, nothing special..

     
  8. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Do you still have the named.conf and rndc.conf symlinked to /etc ?

    Also, what is the directory setting in named.conf?

    here is what we have.

    options {
    directory "/etc/namedb";
     
  9. itrends

    itrends Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    The symlinks are overwritten. I dont know why, everytime i turn around those symlinks are gone ;)

    Thats all i can find for now.. nothin special
     
  10. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Add this to the options

    options {
    pid-file "/var/tmp/named.pid";
    directory "/etc/namedb";
    };

    Then try to restart bind
     
  11. itrends

    itrends Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Hate to say, does nothing..
     
  12. itrends

    itrends Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    still no changes.. cant' get this to work..
     
  13. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    I suggest opening a ticket with cpanel and have them look at the box.
     
Loading...

Share This Page