The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bind problems

Discussion in 'Bind / DNS / Nameserver Issues' started by gemby, Mar 15, 2002.

  1. gemby

    gemby Well-Known Member
    PartnerNOC

    Joined:
    Feb 16, 2002
    Messages:
    182
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Pula, Croatia
    cPanel Access Level:
    DataCenter Provider
    Ia have problems with bind, every now and then it goes down (server is not responding, load 0.00, phone is ringing....)but after restart everything is normal again, and after 10, 15 or 20 hours again. strange is that service status says it's ok.

    ping -t 66.96..222.105 - works
    ping -t www.tramot.com - not working

    after restart - works great

    What could be a problem?
     
  2. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    what's in your /etc/resolv.conf file?
     
  3. gemby

    gemby Well-Known Member
    PartnerNOC

    Joined:
    Feb 16, 2002
    Messages:
    182
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Pula, Croatia
    cPanel Access Level:
    DataCenter Provider
    In my resolv.conf is folowing:

    domain burst.net
    search burst.net hostnoc.net
    nameserver 127.0.0.1
    nameserver 66.96.193.2
    nameserver 66.96.194.2
    nameserver 205.162.50.248
    nameserver 206.228.179.10

    I restarted bind yesterday around midnight, and now seems like everything is ok, but i am just waiting to stop working again. Is there some error log that i can look in?
     
  4. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    [quote:f5340d6631][i:f5340d6631]Originally posted by gemby[/i:f5340d6631]

    In my resolv.conf is folowing:

    domain burst.net
    search burst.net hostnoc.net
    nameserver 127.0.0.1
    nameserver 66.96.193.2
    nameserver 66.96.194.2
    nameserver 205.162.50.248
    nameserver 206.228.179.10

    I restarted bind yesterday around midnight, and now seems like everything is ok, but i am just waiting to stop working again. Is there some error log that i can look in?[/quote:f5340d6631]

    If it crashes again ..take out that 127.0.0.1 in that file and restart and see if it runs forever.
     
  5. gemby

    gemby Well-Known Member
    PartnerNOC

    Joined:
    Feb 16, 2002
    Messages:
    182
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Pula, Croatia
    cPanel Access Level:
    DataCenter Provider
    But i have a lot of name based virtual hosts, are you sure that if i pull that line out, all my virtual servers will be visible to outer world? If apache handels it alone, and ip based vhosts is visible anyway (ifconfig) will it destroy some localhost based stuf?
     
  6. bdraco

    bdraco Guest

    Check /var/log/messages when bind dies.

    --

    What version of bind are you running ?
     
Loading...

Share This Page