The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

bind running,but show "failed" in WHM?

Discussion in 'Bind / DNS / Nameserver Issues' started by tshin, Jan 30, 2005.

  1. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    my bind is 9.2.1
    i use restart BIND in WHM,it shows:
    Attempting to restart named
    Waiting for named to restart.... . . . . . . . . . . finished.

    named status


    named has failed, please contact the sysadmin (result was "named is not running").
    Jan 31 04:45:12 host named[24429]: shutting down
    Jan 31 04:45:12 host named[24429]: stopping command channel on 127.0.0.1#953
    Jan 31 04:45:12 host named[24429]: no longer listening on 127.0.0.1#53
    Jan 31 04:45:12 host named[24429]: no longer listening on xxx.xxx.xxx.xxx#53
    Jan 31 04:45:12 host named[24429]: exiting
    Jan 31 04:45:12 host named: named shutdown succeeded
    Jan 31 04:45:12 host named[24502]: starting BIND 9.2.1
    Jan 31 04:45:12 host named[24502]: using 4 CPUs
    Jan 31 04:45:12 host named[24502]: loading configuration from '/etc/named.conf'
    Jan 31 04:45:12 host named[24502]: no IPv6 interfaces found
    Jan 31 04:45:12 host named[24502]: listening on IPv4 interface lo, 127.0.0.1#53
    Jan 31 04:45:12 host named[24502]: listening on IPv4 interface eth1, xxx.xxx.xxx.xxx#53
    Jan 31 04:45:12 host named[24502]: command channel listening on 127.0.0.1#953
    Jan 31 04:45:12 host named[24502]: zone localhost.localdomain/IN: loaded serial 2005012901
    Jan 31 04:45:12 host named[24502]: running
    Jan 31 04:45:13 host named: named startup succeeded

    ==============
    it shows "failed"
    then,through ssh,type "rndc status"
    it shows:

    number of zones: 4
    debug level: 0
    xfers running: 0
    xfers deferred: 0
    soa queries in progress: 0
    query logging is OFF
    server is up and running

    =============
    looks fine.

    can any one help me?
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    The service that checks services runs approx every 9 minutes. If you restart it from ssh it should show the correct status: service chkservd restart
     
  3. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    thanks.

    but i restarted it though WHM.
    WHM can restart bind,but shows failed.
     
  4. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Nm.. im jetlagged :P
     
    #4 haze, Jan 30, 2005
    Last edited: Jan 30, 2005
  5. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    thank you,haze

    other friends any suggestions?
     
  6. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    What is the OS and version?

    What's the output of "ps aux | grep named"?

    Can you successfully query the name server? Try "host `hostname` localhost"?
     
  7. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    RHEL AS3

    ps aux | grep named

    root 9797 0.0 0.1 66856 2560 ? S 13:10 0:00 named
    root 9840 0.0 0.0 4928 696 pts/0 S 13:18 0:00 grep named


    yes i can query the name server.

    thank you.
     
  8. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    waiting for help...
     
  9. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    The following command should return the ps output for the named process:

    /scripts/restartsrv_named --status

    For some unknown reason it is not on your system (correct me if I'm wrong). Please submit a support ticket to use to my attention (Ben).

    Thanks
     
  10. bikersraw

    bikersraw Active Member

    Joined:
    Feb 16, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    your problem is because named is running as root

    you need to run named -u named.... forget where the config file is though to edit the named command line
     
  11. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    Thanks, I didn't see that (though I was looking directly at it). :)

    Please run /usr/sbin/named-checkconf. That should give you an idea of where the problem lies.
     
  12. TKlaver

    TKlaver Member

    Joined:
    Jan 29, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here:

    I tried the -u named flag as well. Same result.

    Any ideas?
     
  13. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Is this line in your rc.conf file?

    named_flags="-u bind -c /etc/namedb/named.conf"
     
  14. TKlaver

    TKlaver Member

    Joined:
    Jan 29, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Yes, it is. As said in some replies above I tried changing it to -u named also but that didnt make a difference.
     
  15. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Does the named.pid file exist? Paste the options part of your named.conf file here and when your restart Bind, what comes up in /var/log/messages?
     
  16. TKlaver

    TKlaver Member

    Joined:
    Jan 29, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1

    It's restarting every X minutes.
     
    #16 TKlaver, Feb 16, 2005
    Last edited: Feb 16, 2005
  17. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Top into your machine and see if Bind is starting up as username bind. Sounds like it's coming up as username named, should be Bind. If so, you may want to reinstall Bind to see if it fixes the problem.
     
    #17 easyhoster1, Feb 16, 2005
    Last edited: Feb 16, 2005
  18. TKlaver

    TKlaver Member

    Joined:
    Jan 29, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Is there no way to fix that without reinstalling the whole thing?
     
  19. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Try changing ownership on the bind directory and make sure the named.pid file has

    Should be -rw-r--r-- 1 53 bind 6 Feb 16 10:36 /var/run/named/pid

    Our servers have

    /var/run/bind/pid

    If you have the Bind directory, make sure your path in the options section of your named.conf matches.
     
    #19 easyhoster1, Feb 16, 2005
    Last edited: Feb 16, 2005
Loading...

Share This Page