The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

bind server works but displayed failed at whm

Discussion in 'Bind / DNS / Nameserver Issues' started by astar, Jul 27, 2006.

  1. astar

    astar Member

    Joined:
    Jun 15, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    As I've read in other threads on bind server, i guess my problem is not exactly what it is. on root access bind seem working fine as i can lookup other DNS, however in whm server status it gives me an error status failed which i've received its warning emails oftentimes. Bind version is named (9.2.2-P3).
    Hope anyone could give me ideas how to resolve it.

    thank you.
     
  2. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    Restart the service chkservd and also check the "Service Manager" tab on your WHM.
     
  3. astar

    astar Member

    Joined:
    Jun 15, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    i have restarted it many times but it doesn't give any changes to the named status and the named server is enabled too at service manager. my alert named service failure keeps me sending this error. i can't seem to figure out of this.

    pls. help.
     
  4. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    What is your OS?.
    Check the 2 files /var/run/chkservd/bind and /etc/chkserv.d/bind. May be It will help you to solve this issue.
     
  5. astar

    astar Member

    Joined:
    Jun 15, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    HTML:
    What is your OS?.
    Check the 2 files /var/run/chkservd/bind and /etc/chkserv.d/bind. May be It will help you to solve this issue.[/QUOTE]
    
    OS is linux, i could not find bind in both of these path.
     
  6. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    Copy the /etc/chkserv.d/bind from anyone of the server. And also touch the other file. Then restart chkservd.
     
  7. astar

    astar Member

    Joined:
    Jun 15, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    got help from our datacenter techies.
    the line daemon /usr/sbin/named -u named ${OPTIONS} from /etc/init.d/named
    was commented and change to daemon /usr/sbin/root -u root ${OPTIONS}
    and was found out also that user named was deleted.
    after it was added, chkservd was restarted and it works now!

    thanks also for your help bijo :)
     
Loading...

Share This Page