The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bit of Help Please!

Discussion in 'General Discussion' started by SaintDog, Mar 24, 2003.

  1. SaintDog

    SaintDog Member

    Joined:
    Jul 24, 2002
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    All hosting done is on shared servers, though, when my users go to mail.domain.com or ftp.domain.com (and do not already have those created), then it directs them to a website on the server (specifically only one website). The same goes when going directly to the shared servers IP (i.e. shared IP).

    What I need to know is a way to stop this and make it show the default "Apache Installed" as it is basically allowing free promotion to the user on the server which is not fair to others and is something I would like to stop.

    Any help would be appreciated.

    Regards,

    Jonathan
     
  2. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Check httpd.conf

    :)Hello,

    I had same problem for one of my servers. i managed to resolve it. (may be this will work)

    Have a look into your httpd.conf file and just see the first VirtualHost entry, that should be of the Site which is getting displayed when u type in mail.domain.com.

    just add a default Virtual Host entry before that.(Which will display apache default page).

    Hope it Helps!!!!


    Regards,
    ;)
     
  3. SaintDog

    SaintDog Member

    Joined:
    Jul 24, 2002
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I see this entry but not much else besides my users VH entries:

    #<VirtualHost _default_:*>
    #</VirtualHost>

    Should I un-comment that and set the * to my shared IP?
     
  4. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Check VH Entry

    Hello,

    Check youe First VH Entry and that will be for the Domain which comes when u type in mail.something.com. before that VH Entry add a Entry which will display the Default Apache Page. Don't Delete Anything from httpd.conf. u'll land up in a Big trouble.

    Regards,
     
  5. SaintDog

    SaintDog Member

    Joined:
    Jul 24, 2002
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I've checked them all and they all point to my shared IP, none of them are pointing to anything out of the ordinary.

    Anything else that could be a problem?
     
  6. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    This is an example of what the first VH entry should look like:

    NameVirtualHost ServerSharedIPaddress:80

    <VirtualHost ServerSharedIPaddress>
    BytesLog domlogs/ServerHostName.com-bytes_log
    ServerName ServerHostName.com
    DocumentRoot /usr/local/apache/htdocs
    </VirtualHost>

    The "Shared Server IP address" is the first IP address assigned to the Server and the "Server Host Name" is always a Sub-domain.
     
  7. SaintDog

    SaintDog Member

    Joined:
    Jul 24, 2002
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Edit: Things are now working, thanks everyone for their help :).
     
    #7 SaintDog, Mar 27, 2003
    Last edited: Mar 27, 2003
Loading...

Share This Page