The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

:blackhole: , :fail:

Discussion in 'General Discussion' started by Curious Too, May 7, 2002.

  1. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Mail being sent to legitimate usernames is being blackholed or bounced if the user has set their default (catchall) email address to :blackhole: or :fail: -- Has anyone else experienced this? The only way to get around it is to create an email account in CPanel for the primary username. Is this how this feature is supposed to work?
     
  2. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    I've just tested it (with :fail:) and it seems to work as expected. Messages to existing accounts are correctly delivered, and all other messages are rejected.

    See /var/log/exim_mainlog, it will help you find out where the problem lies.
     
  3. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    This is what is happening -- say an account's primary username is &janedoe& --

    instead of having the default address set to:

    *: janedoe it's set to *: :fail:

    What's happening is ALL email sent to the account is failing, including email sent to janedoe@herdomain.com -- my understanding is that email sent to anybody@herdomain.com should fail, but email sent to janedoe@herdomain.com should be delivered. Is my assumption correct?
     
  4. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Can you post the entire contents of the valias file here? Well, in ambiguously secretive anonymity, of course...

    It might be of some help to see the entire thing.

    :p
     
  5. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    [quote:e31340ad78][i:e31340ad78]Originally posted by feanor[/i:e31340ad78]

    Can you post the entire contents of the valias file here? Well, in ambiguously secretive anonymity, of course...

    It might be of some help to see the entire thing.

    :p [/quote:e31340ad78]

    here's the entire contents of the valias file:

    *: :blackhole:

    Now here's the routing of an email sent to the domain -- the username for the domain is &cenlinks&

    2002-05-12 01:15:29 176lhh-0004NJ-00 &= curious2@telocity.com H=h000.c003.snv.cp.net (c003.snv.cp.net) [209.228.32.214] P=smtp S=894 id=05fd01c1f972$d10c0b60$d99bc140@default

    2002-05-12 01:15:29 176lhh-0004NJ-00 =& :blackhole: anybody@census.com D=virtual_aliases

    2002-05-12 01:15:29 176lhh-0004NJ-00 Completed

    2002-05-12 01:15:29 176lhh-0004NK-00 &= curious2@telocity.com H=h000.c003.snv.cp.net (c003.snv.cp.net)
    [209.228.32.214] P=smtp S=895 id=05fd01c1f972$d10c0b60$d99bc140@default

    2002-05-12 01:15:29 176lhh-0004NK-00 =& :blackhole: cenlinks@census.com D=virtual_aliases

    2002-05-12 01:15:29 176lhh-0004NK-00 Completed

    Shouldn't the mail sent to cenlinks@census.com have been delivered ok?
     
  6. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    Ah, ok, I misunderstood.

    It happens exactly as you describe.

    Actually, if you create janedoe@herdomain.com, then janedoe and janedoe@herdomain.com are two different accounts, each with its own inbox file, login and password. janedoe is really janedoe@host.ispdomain.com. It's a user, like root, with a username, a password and a homedir (where mail goes) as defined in /etc/passwd.

    I think that the best to understand it is testing Exim like this:

    /usr/sbin/exim -bt -d2 account@herdomain.com

    with different variations (main account, existing account, non-existing account, and with different catch-all accounts). For greater detail use -d9 instead of -d2. You'll see the steps Exim follows to determine where the inbox of each account is.

    From the above you'll see that another possibility would be to define an alias like this:

    janedoe@herdomain.com: janedoe@host.ispdomain.com

    (only &janedoe@herdomain.com: janedoe& won't work from within Cpanel, but it will if you add it yourself to /etc/valiases/herdomain.com).
     
  7. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    So users who want to turn off the &catchall& feature of their account must first create an email account for the primary username?

    On my boxes that use sendmail I have this in the virtusertable for people who want the catchall feature disabled:

    @domain.com /dev/null

    The mail still gets delivered to the primary username but all other mail gets bounced. I thought Exim would work this way also, but apparently not.
     
  8. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    [quote:75c4679f4c][i:75c4679f4c]Originally posted by Curious Too[/i:75c4679f4c]
    So users who want to turn off the &catchall& feature of their account must first create an email account for the primary username?[/quote:75c4679f4c]

    Either that or create an alias as I explained. Probably there are other ways but I don't know.
     
Loading...

Share This Page