The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

:blackhole: question

Discussion in 'General Discussion' started by Slav, Sep 16, 2004.

Thread Status:
Not open for further replies.
  1. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Hi, i am hoping someone can answer this for me. I have logged a call with the budzilla but they said this is not a bug. So i am hoping someone can answer this for me.

    An example.
    Lets say you create a account in whm and then that customer has the main default email account you set this to :blackhole: that is fine. Then you create a additional account a POP3 and use it. How come you can send mail to the new created POP3 account all okay but anything being sent to the default does not go through. I know that the unrouted mail will fail but how come does the default email address fail to? The only way i can fix it is to remove the blackhole function and then it works but then all the junk comes in. SO i cant win. :(

    Our version we run is.

    WHM 9.9.0 cPanel 9.9.0-E43
    RedHat 9 i686 - WHM X v3.1.0

    I do feel there is something not right here as its more then one person has complained about this to us. ]

    Has anyone else got this problem or i have lostt he plot?

    Thanks Slav
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    :blackhole: means the mail disapears and no failed message is sent out, thats the whole point.
    :fail: means messages will fail, and an error message will be produced and sent back to the user.

    You can change this behavior within cpanel under the mail menu "Edit default email account" or something of that nature.
     
  3. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Hi yes i understand that, but it should still pass mail to the default email account if it was addressed as username@domain.com username being the username of the domain account .
    So if i create a account called domain.com the useranme for that acocunt is username then i go to set the default to blackhole on the email address username@domain.com . In this i should be able to send mail to username@domain.com and it should get it still. only mail not addressed tot hat mail address should be blackholed. ???
     
  4. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    No, it shouldn't. The whole point is to NOT receive email AT ALL with either :fail: or :blackhole: set. There is a discription of each of these when you are at the management screen within cpanel. The whole point is to rid yourself of a "catchall" email account. The only difference between the 2 settings is that one bounces back an error message, and the other doesn't.

    As taken from the cpanel documentation:

    Any e-mail that is sent to an unknown account at your domain name, such as unknown@yourdomain.com, gets automatically rerouted to your default e-mail account. All web site accounts are automatically assigned a default e-mail address - user@yourdomain.com - which you can change, if required.

    To set your default e-mail address:

    1. Click on the Default Address link in the Mail area.
    2. Click on the Set Default Address link.
    3. Enter the complete e-mail address of the new default in the field next to your web site name drop-down list.
    Note: You can enter :blackhole: to throw away all incoming mail, or :fail: no such address here to bounce the e-mail back to the sender.
    4. Click on the Change button. Your new default e-mail address has now been set.
     
  5. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    oh okay. i was under the impression you should get some mail through. So blackhole disables the whole email account. Opps. I will remeber that. Thanks makes more sense now. I as is aid i thought i should get some mail. So having it set in whm to create a blackhole function when creating sa new account is not a good idea as if they dont create another pop3 account they will never get mail.

    Thanks for that.
    Slav
     
  6. webits

    webits Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    114
    Likes Received:
    0
    Trophy Points:
    16
    If you do set :blackhole: / :fail: all e-mails wont be receied in Default account. Just deactivate that :blackhole: then you'll receive e-mail in the default account or just create another e-mail address with the same name :)
     
  7. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Thanks

    Slav
     
  8. belaus

    belaus Member

    Joined:
    Mar 30, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    THis doesn't sound logic to me...

    I have customers for instance that DO want to use the main account (username@domain.com) as being a correct email address their correspondents can send email to directly, but they do indeed want to blackhole any email sent to a non-explicitely created or existing email account...

    The "main" email account is not an account that should be blackholed at all...

    Let's say we have an account with username "main"

    we create three email accounts manually, being sub1, sub2 and sub3
    How can we now make sure email to

    - main@domain.com
    - sub1@domain.com
    - sub2@domain.com
    - sub3@domain.com

    are being accepted while rubbish@domain.com is being blackholed?
    This should be normal behaviour; it's not because we don't want rubbish@domain.com to be delivered, that we don't want the main@domain.com account to be disfunctional too, is it? :)
     
  9. surf chick

    surf chick Active Member

    Joined:
    Feb 12, 2004
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    The default address maintenance page says "All unrouted mail will be sent to:" so that means any mail sent to username@example.com will go to the address you specify(or :fail: / :blackhole: ) unless you set up an account for username@example.com on the Manage/Add/Remove Accounts page. At least, that's how it seems to work for me.

    AFAIK, the main account is set up automatically when your web host account is configured in WHM and the address is yourcpanelloginname@example.com. You can't delete or change this in cpanel.

    So...just set up those accounts you want:
    - sub1@domain.com
    - sub2@domain.com
    - sub3@domain.com

    and :blackhole: the rest. BTW, my understanding is that you should set the default to :fail: in preference to :blackhole:.
     
    #9 surf chick, Feb 28, 2006
    Last edited: Feb 28, 2006
Loading...
Thread Status:
Not open for further replies.

Share This Page