The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

:blackhole: set kills users SMPT

Discussion in 'E-mail Discussions' started by smoge, May 13, 2007.

  1. smoge

    smoge Well-Known Member

    Joined:
    Jul 2, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    I have a user on a server hosting many domains.

    Other users have not reported any problems with mail, and we also use the server for some of our own sites with no problems.

    However, this one user, if the Default Address is set to :blackhole:, the user is unable to receive mail to his primary email account, for example myaccount.

    (myaccount and myaccount@myaccount.co.uk are simply examples)

    To troubleshoot - I set it to :fail: no such address here to see how it would bounce

    myaccount@myaccount.co.uk
    SMTP error from remote mail server after RCPT TO:<myaccount@myaccount.co.uk>:
    host myaccount.co.uk [123.123.123.123]: 550-"The recipient cannot be verified. Please check all recipients of this
    550 message to verify they are valid."

    If I remove :blackhole: (and/or :fail: no such address here) from the Default Address settings, it works fine.

    The only difference is between this account and any of the othes running on this server is that it is a co.uk domain.

    Thanks for any input,

    Smoge (Rob LeVine)
    http://www.modmysite.com
     
  2. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
  3. smoge

    smoge Well-Known Member

    Joined:
    Jul 2, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    Yes - but :fail: has the same result in this case - mail sent to the valid account email gets bounced.

    :)

    On additional thought... I did not try setting up a new account (as the user wanted to use the one cpanel account email) - but I will do that - and see if the same problem exists with a newly generated additional account and report back what happens.

    Smoge
     
  4. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    It sounds like you do not have myaccount@myaccount.co.uk setup as an actual mail account.

    It sounds like the username for the domain name account myaccount.co.uk is myaccount and you are wanting to use this e-mail account.

    Notice the difference in the POP/IMAP username that you are using to check for mail. If you are using just myaccount then you are accessing the account's default box. The default box isn't just for myaccount@myaccount.co.uk, it is also for asdf@myaccount.co.uk, jkl@myaccount.co.uk, tom@myaccount.co.uk, mary@myaccount.co.uk, etc. assuming that you do not have any of those e-mail addresses set up as forwarders or POP/IMAP accounts. The default box is where anything@myaccount.co.uk will go. Commonly this is just a haven for spam because spammers will just send e-mail to any address they can think of @myaccount.co.uk.

    I suspect that you are only interested in receiving e-mail that is specifically destined for myaccount@myaccount.co.uk. If that is the case, then you need to set up myaccount@myaccount.co.uk as a POP or IMAP account in your control panel and assign it a unique password. Now when you go to set up your e-mail client or log in via webmail, the username of the account that you are checking will be myaccount@myaccount.co.uk.

    This account will only accept mail that is specifically sent to myaccount@myaccount.co.uk. If someone sends a message to asdf@myaccount.co.uk and you do not have asdf@myaccount.co.uk set up as a POP/IMAP or forwarder, then this message will be destined for the default box on myaccount.co.uk. If the default box is set to :fail: then this message will be outright rejected (which is what you want to do).

    Hope this helps.
     
  5. smoge

    smoge Well-Known Member

    Joined:
    Jul 2, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Ok - I took your suggestion and setup a "real" myaccount@myaccount.co.uk email account - so now there is two - one with the logon of "myaccount" (the default cpanel account email) and one with the login of "myaccount@myaccount.co.uk."

    I re-enabled :fail and did a test and it worked.

    Thanks for the help.

    Smoge
     
Loading...

Share This Page