Blacklisted email still coming through

Bob Suhaili

Registered
Apr 8, 2018
3
0
1
Malaysia
cPanel Access Level
Website Owner
Hi,

Sorry if this has been asked before.

I have a blacklist on cpanel to block regular spammers, mostly corporate spam. I've noticed that sometimes the spam would get through and sometimes it is blocked. Is that normal?

Example:
Code:
spam email from; [email protected]

Event: success
User: -remote-
Domain:
From Address: [email protected]
Sender:
Sent Time: Jun 26, 2018, 1:34:01 AM
Sender Host: mail.example-domain.com
Sender IP: 182.239.xx.xxx
Authentication: localdelivery
Spam Score:
On my blacklist I've added before "*@*domain*" but the same spam email is still coming through.

Thanks for any advice.
 
Last edited by a moderator:

keat63

Well-Known Member
Nov 20, 2014
1,387
108
93
cPanel Access Level
Root Administrator
If youre using exim_blacklist, then I found this could happen occasionally.
Since switching to CSF Mailscanner, now nothing gets through.

As a matter of interest, I actually removed exim_blacklist just this morning.
 

Bob Suhaili

Registered
Apr 8, 2018
3
0
1
Malaysia
cPanel Access Level
Website Owner
Hi,

What have you set the blacklist action? To mark as spam and deliver or reject?
Can you share with the screenshot of the filter set?
I've set the blacklist to blackhole (dev/null) and the list is something like this:


blacklist_from: *@*conference*

blacklist_from: *@*trainer*

etc

If youre using exim_blacklist, then I found this could happen occasionally.
Since switching to CSF Mailscanner, now nothing gets through.

As a matter of interest, I actually removed exim_blacklist just this morning.
Thanks, just buggy I guess so its not just me. I'll lookup and see if I have other options since I don't have root access.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
I've set the blacklist to blackhole (dev/null) and the list is something like this:


blacklist_from: *@*conference*

blacklist_from: *@*trainer*

etc
Hello,

Can you post a screenshot from the cPanel UI so we can verify the exact settings you are using, and where you are setting them?

Thank you.
 

Kendrick357

Registered
Jul 31, 2018
1
0
1
Nashville, TN
cPanel Access Level
Root Administrator
I have something very similar to what is happing here. My problem is that spam is still getting through with no subject line nor "To:"
I have uploaded attachments that show what I'm talking about. I am not sure if this has been posted on here because i am new to cPanel have only been using for a month or two. Please if anyone has any ideas please help.
 

Attachments

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
I have something very similar to what is happing here. My problem is that spam is still getting through with no subject line nor "To:"
I have uploaded attachments that show what I'm talking about. I am not sure if this has been posted on here because i am new to cPanel have only been using for a month or two. Please if anyone has any ideas please help.
Hello @Kendrick357,

The first image you attached shows a bracket at the end of domain name in the third blacklist_from field. This is not a supported character. Can you remove it and save the changes to see if the issue persists?

Note that internal case CPANEL-19104 is open to ensure the blacklist_from and whitelist_from fields are properly validated in the UI.

Thank you.

04-02-2019 Update: CPANEL-19104 was closed due to a lack of new support requests. Please feel free to reply to this thread if this issue continues to present a problem.
 
Last edited: