The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Blacklisted SMTP IPs does not appear to be working

Discussion in 'E-mail Discussions' started by TMX, Oct 5, 2011.

  1. TMX

    TMX Member

    Joined:
    Mar 18, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    WHM 11.30.4 (build 6) on centOS 6

    The blacklist smtp IPs feature, accessible at:

    Exim Configuration Editor -> Access Lists -> Blacklisted SMTP IPs

    is not working at all on either individual IPs or entire IP blocks. Entering an IP in this area has no effect whatsoever. Noticed this on several nototrious (to me) spammer IPs, and verified this morning using the IP addresses of an outside email account I keep for test purposes.

    here's a sample transaction from the exim_mainlog. 75.180.132.121 was listed individually and as part of a /24

    2011-10-05 11:11:37 H=cdptpa-omtalb.mail.rr.com [75.180.132.121] Warning: Sender rate 2.0 / 1h
    2011-10-05 11:11:37 1RBT8D-0003AJ-EB <= mytestaddy@nc.rr.com H=cdptpa-omtalb.mail.rr.com [75.180.132.121] P=esmtp S=1106 id=20111005151137.SWICW.10356.root@cdptpa-web03-z02
    2011-10-05 11:11:37 1RBT8D-0003AJ-EB => me <me@mylocaldomain.com> R=virtual_user T=virtual_userdelivery
    2011-10-05 11:11:37 1RBT8D-0003AJ-EB Completed

    Thanks,
    -Bob
     
  2. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Have you done a "save" on both the edit portion of the "Edit Blacklisted SMTP IPs" screen and the Exim Configuration Editor that rebuilds and restarts Exim?

    Seem to recall situations where only saving the edited file doesn't pickup the changes.
     
  3. Secmas

    Secmas Well-Known Member

    Joined:
    Feb 18, 2005
    Messages:
    321
    Likes Received:
    0
    Trophy Points:
    16
    Sorry to resurrect an old thread, but right now it is happening to me.

    My cPanel ver. 11.48.4 (build 4)
    I have added a few IP lines, I saved this and saved and restarted EXIM but this is not working.

    Any inputs?

    Thx in advance.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. Secmas

    Secmas Well-Known Member

    Joined:
    Feb 18, 2005
    Messages:
    321
    Likes Received:
    0
    Trophy Points:
    16
    Thank you Michael.

    I opened a ticket directly to cpanel before you posted your answer and Angela fixed the issue, it seems that a switch to turn this on wasn't set on the Advanced Editor. Before I resurrected this old thread, I looked there and didn't saw this little box that has to have a check on it in order to work. It will be great to make us life easier to have this box on the Basic Editor :)

    Once again, thanks for your kind answer.

    By the way, after setting this box checked, all the IPs that I had in my list started to work and thousands of emails are stopped at that stage.

    Sergio
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page