Widmo

Member
Aug 4, 2005
11
0
151
Hello, i've a problem with WHM and yum.

in WHM i have empty RPM list, and using yum is impossible. i get this error after:
Code:
yum update
Code:
[[email protected] widmo]# yum update
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
rpmforge  :                                                    1/7669Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 97, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 477, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 955, in updatePkgs
    self.doRepoSetup()
  File "/usr/share/yum-cli/cli.py", line 75, in doRepoSetup
    self.doSackSetup(thisrepo=thisrepo)
  File "__init__.py", line 260, in doSackSetup
  File "repos.py", line 287, in populateSack
  File "sqlitecache.py", line 96, in getPrimary
  File "sqlitecache.py", line 89, in _getbase
  File "sqlitecache.py", line 359, in updateSqliteCache
  File "sqlitecache.py", line 251, in addPrimary
  File "sqlitecache.py", line 197, in insertHash
  File "sqlitecache.py", line 449, in values
  File "sqlitecache.py", line 441, in __getitem__
  File "mdparser.py", line 73, in __getitem__
KeyError: 'epoch'
as google said to install sth i unstalled some rpmforge rpm :(

how to disable this repo and back to previous settings?

Code:
yum --disablerepo=rpmforge update
not fix problem
 

Widmo

Member
Aug 4, 2005
11
0
151
i've fixed problem myself :D

Code:
pico /etc/yum.repos.d/rpmforge.repo

Code:
enabled = 1
change to


Code:
enabled = 0
than

Code:
yum clear all
yum update
yum upgrade
/scripts/yumup
/scripts/upcp

sajo-na ra
alivederchi
bye-bye

www.widmo.biz