The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

blocked with too many connections on FTP

Discussion in 'General Discussion' started by Metro2, Aug 2, 2007.

  1. Metro2

    Metro2 Well-Known Member

    Joined:
    May 24, 2006
    Messages:
    376
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Hi all,

    I'm hoping someone might have a clue for me as to what might be going on with a particular customer on one of my dedicated's. I use ConfigServer's CSF/LFD scripts, and this customer keeps getting "blocked with too many connections" when he FTP's in and tries to download his public_html folder to his computer.

    Here's an example of an LFD alert I typically receive when he tries to FTP and gets blocked:

    Time: Thu Aug 2 16:00:59 2007
    IP: xx.xxx.xx.xxx (ppp-xx-xxx-xx-xxx.dsl.hstntx.swbell.net)
    Connections: 878
    Blocked: temporarily

    When I check the lfd.log file all I see for it is this:

    Thu Aug 2 16:00:59 2007 lfd: (CT) IP xx.xxx.xx.xxx found to have 878 connections - *Blocked in csf* for 1800 secs

    At first I suspected that it might be his FTP client, so I had him try a different one. Same results.

    This problem doesn't happen with any other customers.

    Is it possible that his computer might be compromised and that maybe some form of malware on his system is creating extra connections when he logs in to FTP? (I have asked him to run some security scans on his system, waiting for results).

    Are there other possibilities that anyone here can think of that might cause him to have "800 connections" simply by FTP'ing in to the server and downloading his web site?

    Thanks for any opinions / advice, I appreciate it.
     
  2. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    Just set the number of download threads in his client.
     
  3. Metro2

    Metro2 Well-Known Member

    Joined:
    May 24, 2006
    Messages:
    376
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Thanks for the response lloyd. CuteFTP defaults to only 4 threads but we can try setting it to 1. But still I'm not convinced that's the issue since I have many customers using the same FTP software and settings and none of them encounter this problem. Wouldn't I see this happening to all customers who use the same FTP software and settings as this guy?
     
  4. bornonline

    bornonline Well-Known Member

    Joined:
    Nov 19, 2004
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    I have seen this too. I set Maxclients in pure-ftp conf to like 8 connections per IP.
    Then type
    root@server [/etc]# /usr/sbin/pure-config.pl /etc/pure-ftpd.conf
    Running: /usr/sbin/pure-ftpd -A -c50 -B -C4 -D -E -fftp -H -I15 -lextauth:/var/run/ftpd.sock -L2000:8 -m

    You could try something like this. It has worked for me.
     
  5. Fernis

    Fernis Well-Known Member

    Joined:
    Oct 28, 2006
    Messages:
    192
    Likes Received:
    1
    Trophy Points:
    18
    Would you mind explaining what this does?
     
  6. bornonline

    bornonline Well-Known Member

    Joined:
    Nov 19, 2004
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Sets the max FTP(pure-ftp) connections to eight per IP address.
     
  7. Fernis

    Fernis Well-Known Member

    Joined:
    Oct 28, 2006
    Messages:
    192
    Likes Received:
    1
    Trophy Points:
    18
    This would accomplish the same thing as editing the pure-ftpd.conf, such as?

    # Maximum number of sim clients with the same IP address

    MaxClientsPerIP 8
     
  8. bornonline

    bornonline Well-Known Member

    Joined:
    Nov 19, 2004
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Yes, but not until you run "/usr/sbin/pure-config.pl /etc/pure-ftpd.conf" after the change in the conf file. Just changing the conf file did not work for me.

     
    #8 bornonline, Aug 4, 2007
    Last edited: Aug 4, 2007
  9. Fernis

    Fernis Well-Known Member

    Joined:
    Oct 28, 2006
    Messages:
    192
    Likes Received:
    1
    Trophy Points:
    18
    Would you mind posting or Pming me your pure-ftpd.conf?
     
  10. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16

    Did you restart the FTP server? You need to restart te server after editing the config.
     
  11. Metro2

    Metro2 Well-Known Member

    Joined:
    May 24, 2006
    Messages:
    376
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Still running into this issue even after checking the settings in pure-ftpd.conf and restarting FTP services in WHM.

    Only happens with a few users our of hundreds, but those few are obviously frustrated and wondering why I don't have a fix for them.

    Anyone else still have this problem?
     
  12. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    How many concurrent connections do they have set in their ftp client? I would guess that is the problem, for those few.
     
  13. gtgeorge

    gtgeorge Well-Known Member

    Joined:
    Feb 28, 2007
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    6
    I saw this occur on one of my own accounts last year when using Filezilla set at 2 connections. I changed it to 1 and had no more problems. Ask those users which ftp software and the # of concurrent connections they are set to.
     
Loading...

Share This Page