The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Blockers for New Installations of cPanel & WHM

Discussion in 'cPanel Announcements' started by Infopro, Feb 13, 2014.

  1. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    With the latest version of our installer, new installations of cPanel & WHM software will be subject to the following blockers:

    • The target version must be cPanel & WHM version 11.40 or higher.
    • For CentOS, CloudLinux, or RHEL operating systems, the installation must be version 6 or higher.

    If either of these statements are not true, the installation will fail. These blockers are meant to encourage system administrators to use the most up-to-date software, which will prevent future issues.

    To allow additional time for anyone whose servers do not yet meet these requirements, you can perform the following actions:*

    • Install cPanel & WHM version 11.38 as the target version.
    • For CentOS, CloudLinux, or RHEL operating systems, install on version 5.

    Code:
    [B]*[/B]When running the installer, you must use the --force command line option. 
    For example, sh latest --force or sh latest-dnsonly --force

    These blockers will not affect existing installations of cPanel & WHM. However, we strongly encourage system administrators to always upgrade their servers’ software to the newest version as soon as possible.
     
    #1 Infopro, Feb 13, 2014
    Last edited: Feb 15, 2014
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I have seen a couple of requests for clarification on how to force the installation of cPanel in situations where using the most up-to-date software is not desired. The only difference compared to a normal installation is you must use the "--force" command-line option when running the installer.

    Examples:

    Code:
    sh latest --force
    sh latest-dnsonly --force
    Thank you.
     
  3. loganfoster

    loganfoster Registered

    Joined:
    Jan 27, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    DataCenter Provider
    Just to clarify, will existing cPanel/WHM installations running on CentOS 5x continue to be able to update to the latest versions up to and beyond 11.40.x? Do you have any plans to cease support completely for CentOS 5x in the near future?
     
  4. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider

    Yes, servers running CentOS 5 will still be able to upgrade normally. However, pursuant to cPanel's EOL policy, CentOS 5 will stop being supported in 2017:

    Operating System End of Life Policy for cPanel & WHM
     

Share This Page