Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Both SCGI and suEXEC are enabled

Discussion in 'EasyApache' started by BobSmith123, Oct 22, 2016.

  1. BobSmith123

    BobSmith123 Member

    Joined:
    Apr 5, 2015
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    USA
    cPanel Access Level:
    Website Owner
    I just updated to cPanel 60. I got an email saying this:

    Both SCGI and suEXEC are enabled. On the “Configure PHP and suEXEC” page toggle “Apache suEXEC” off then back on to disable SCGI.

    I run CloudLinux w/ mod_lsapi and EasyApache 4. I ran the command /usr/local/cpanel/bin/rebuild_phpconf --current and it said the following:

    DEFAULT PHP: ea-php70
    ea-php70 SAPI: suphp

    mod_lsapi is a drop-in replacement for suphp, so it is not surprising the the script returns that suphp is enabled. However, I don't see scgi or suexec enabled. What is going on?

    Thanks!
     
    #1 BobSmith123, Oct 22, 2016
    Last edited by a moderator: Oct 23, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The "/usr/local/cpanel/cgi-sys/scgiwrap" script is deprecated as of cPanel version 58. Internal case CPANEL-9285 removes /usr/local/cpanel/cgi-sys/scgiwrap as of cPanel version 62. In the meantime, check the permissions on this file with a command such as:

    Code:
    ls -al /usr/local/cpanel/cgi-sys/scgiwrap
    If it's set to 0755, you can disable it via command such as:

    Code:
    chmod 0400 /usr/local/cpanel/cgi-sys/scgiwrap
    chmod +t /usr/local/cpanel/cgi-sys/scgiwrap
    You can then browse to "WHM >> Security Advisor" to verify if the warning message still appears.

    Thank you.
     
Loading...

Share This Page